TechSpot

Floopy Drive No Work

By Cybermonk
Apr 21, 2003
Topic Status:
Not open for further replies.
  1. I recently bought a new sony floopy drive, installed it, worked fine for a day, then all of a sudden, it wants to format every single formated disk i put in there....i cleared the CMOS, uninstalled and installed the floopy drive, i even tried it on another P.C., works there, please help....

    I'm running Windows 2000, upgraded from Win98.


    -Cybermonk
  2. prime2515102

    prime2515102 TS Rookie

    This is just a shot in the dark but, check your BIOS and make sure Floppy Mode 3 support is disabled and "report no FDD for OS" is also disabled.

    Prime
  3. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    When you switched systems, did you use a different FDD cable? It is possible your FDD ribbon cable is bad.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.