Fps issues with games

By Demontk13
Aug 17, 2009
  1. Alright I'm running a custom built PC specs will be at the bottom of the page this computer used to run WoW at full specs and resolution wonderful until recently i don't know why it would all of a sudden just drop like it did so i'm here i used to play full specs like i said FPS would be anywhere from 150-200 something anywhere i went but not i have to drop all video specs to lowest possible just to get 60 FPS and it's still a bit laggy it isnt just with WoW that i notice these issues all drivers are updated to the the newest releases unless something came out in the past 3 weeks

    Here are my specs

    Video card - msi nvidia geforce 9800gx2

    Mother board - P32 neo2 FR/FIR

    CPU - Intel Q9300 Quad core 2.5ghz NOT overclocked in anyway

    OS - Windows xp professional sp3

    RAM - Patriot viper DDR2 4gig sees 3gig

    Power supply - 1200 watt

    If you need any further information just let me know
  2. klepto12

    klepto12 TechSpot Paladin Posts: 1,115   +9

    well first of all you didnt get 150 to 200 fps in wow with settings at max. my rig doesnt get that and i have a gtx 260 and a q9550 clocked at 3.8Ghz. make sure you turn shadows off its is the biggest fps hog on wow and you should be able to run the game fine unless 1 of the gpus died in you GX2
  3. Demontk13

    Demontk13 TS Rookie Topic Starter

    Yes i did get 150-200 i have screen shots the gpus in the video card are both fine ran tests on it

    and i never used shadows kinda ****ed with my eyes
  4. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,433   +143

    That doesn't count as max O.o.

    That means you didn't do ANYTHING, and that the drop occurred randomly one day right?

    I noticed that you havn't yet typed in a period here at techspot.
  5. Demontk13

    Demontk13 TS Rookie Topic Starter

    i never said anything about max and what do period have to do with needing help ? hahaha

    . <---
  6. LinkedKube

    LinkedKube TechSpot Project Baby Posts: 3,481   +44

    I'm not sure what kind of mobo you have, and you didnt say the make of your psu either. What resolution are you gaming at that you can get 200fps, i loaded up wow on max setting with 80 fps, but my resolution is pretty high.

    Make sure you didnt change the resolution to something higher than you had it before.
  7. Adhmuz

    Adhmuz TechSpot Paladin Posts: 1,617   +494

    Well he did say that it was with more games than just WoW, and honestly WoW is not a very good benchmark, too much happening one minute and nothing the next (IE Lots of walking) can you give us examples of other games that you have notice the drop, also run all the virus scans and spy ware scans you can. Let me know how that runs out. And periods are important. This isn't English class but it nice when people take their time asking for help. They tend to be taken more seriously...
  8. Demontk13

    Demontk13 TS Rookie Topic Starter

    im just going to dump everything on the computer again and put vista on it
  9. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    Haha, English police? :D

    You always need one of those on each forum.

    How will Vista change your performance? Won't it just slow it down even more
  10. Demontk13

    Demontk13 TS Rookie Topic Starter

    i dont know im just so frustrated with this crap that im about to just stop pc gaming altogether
  11. adamantell

    adamantell TS Rookie

    make me LAUGH :d

    i got "150-200" fps all maxed.

    ok running at 800x600 ? what RES dude...

    also problem will be over heating, or lastest driver update.

    take card out BLOW IT WITH COLD HAIRDRYER if skilled, take it apart and rebuild clean before do ofc.

    lol and WoW = Crap game, play d2...

    200FPS loooooooool epic fail
  12. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    Try this program here.

    It stops all unneeded processes/programs from running when you select 'Game Mode'

    You can then select 'Normal Mode' to restore all these processes.

    See if this helps. You may have installed programs recently, that are loading and hogging your resources.

    Have you run any malware scans? They are common cause of system slow ups.

    Note: I'm just adding software suggestions, not hardware at this point
  13. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,433   +143

    Hardware is least likely, and I don't think you should try and take apart your graphics card o.o.

    I think it is probably a software problem, but I don't know what.
  14. Demontk13

    Demontk13 TS Rookie Topic Starter

    1680 x 1050 is the res and adamantell if your going to be a **** don't bother posting i like WoW reguardless if you think it sucks or not it's my choice thanks i have run all scans i could possibly run ccleaner driver cleaner avg and some malware removal program i can remember the name the video card is clean as a whistle i used a compressor to blow out the inside of the machine took the vga off the mainboard and did that one seperate the computer runs and the overheating can't be anything its 59c in games it's 63c for cards inside the vga case

    the psu is a 1200watt greenpower
  15. Demontk13

    Demontk13 TS Rookie Topic Starter

    and my bad about the 150-200 fps i was thinkin of another game AT max settings shadows and all the computer used to run at 100-105 FPS give or take a little depending on where i was right now the only thing i have turned up is the view distance and im getting 60 fps constantly some lag when i turn and do certain things as well

    forgot to say in the post above that all drivers are up to date unless they released something over the course of the day
  16. snowchick7669

    snowchick7669 TS Maniac Posts: 660

    Did you try my suggestion in my previous post?
  17. Demontk13

    Demontk13 TS Rookie Topic Starter

    working on your suggestion now :D
  18. Demontk13

    Demontk13 TS Rookie Topic Starter

  19. adamantell

    adamantell TS Rookie

    Was not being a ****, just happy see you have nice res :) shame its not 1080p but never the less nice.

    btw are you running with AA (dunno if wow support that)

    anyhowi think i know what problem is

    i had same problem with COD4 really i running QX9650 two 4870X2 8gb ram, @1920x1200 high AA on etc and my frames was 60 none stop always, then one day randomly it went 20-30 and started jumping and lagging

    i reformated, and all was fixed (Windows 7 MSDN 64bit)

    maybe try that, if you got all on ex-harddisk like me only takes 1 hour sort out
  20. Demontk13

    Demontk13 TS Rookie Topic Starter

    yeah im reformatting to xp legit version cleaning everything out next monday when i have time i dont want to put windows 7 on the computer right now as its going to expire ill wait till its released :D aa anti aliasing ?
  21. Demontk13

    Demontk13 TS Rookie Topic Starter

    i could run this comp on my 37 inch wide screen hd tv thats sitting here doing nothing but when i do that the **stuff** all blurry haha

    **watch the vulgarity - it's frowned upon here**
  22. adamantell

    adamantell TS Rookie

    Yeh AA, Anti Aliasing

    Windows 7 MSDN with CRACK wont expire... its same as the vista crack and the xp crack, just in windows 7 now :d my freind been using vista crack for almost 2 years and a m8 been running the xp pro crack for ermmm 6 ? LOL

    install windows 7, dude trust me on that its xp speed (little faster i think) with vista style

    realllly kicky realllly nice stuff !!!

    try turn off AA or down a little if you was running it sometimes, this just goes lame on a driver update, also what driver you running i guess lastest ? try going back a few driver versions ! again sometimes that can fix this lame problem you got.

    what AV / FIREWALL you running ? if its bitdefender turn off firewall just for test, as when i used have this problem it gave me problems randomly in games, now it has gamemod, also try with that on!

    ermmmm runnin low on iedas !!! remforated is the best thing like :D

    if your, 37ich screen is not FULL 1080P that sure it will be ugly as the res is something lame like 13xx by 9xx your montior is higher :d if was FULL 1080P then trust me its way better i sometimes hock my rig up 2 my SONY W4500 and omg :D crysis looks sick !
  23. Demontk13

    Demontk13 TS Rookie Topic Starter

    windows firewall is turned off thats all thats on here and the tv is 1080p i just have to adjust the res on the computer to make it look better im just lazy haha

    how about this windows 7 stuff hook me up ill try it the xp i have now is the cracked version
  24. adamantell

    adamantell TS Rookie

    i cant seem post links or anything... says need more posts LOL
  25. Demontk13

    Demontk13 TS Rookie Topic Starter

    email me edited email out
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...