FPS loss in CS

By [SU]Mantis
Apr 1, 2003
  1. FPS loss in CS with 9700 all-in-wonder

    First off I'm new here and I'm not all that tech savy but I can make my way around my comp... I'm learning everyday with the help of my friend who assisted me in building my first box.

    I built this sytem pretty much for gaming, home entertainment, school and work... Everything runs great except the game I love to play Counter Strike. I have no problems with more demanding games like BF1942 or DF BHD.

    The problem is I'm loosing frame rate when I get a lot of people on my screen. It's not my connection because my cable is beautiful, I get 2200ms dls at worst. I will have 100 fps constant then all of a sudden a few people come into view and I can drop down to 30 fps on certain ocassions, depending on the map. I have all the latest drivers for my card, and board. I just dont know what it could be and I'm getting really frustrated.

    If there is anyone out there who can give me any ideas please let me know. There is no reason this beast of a system (for me at least :eek: ) should be doing this. A buddy of mine said it could possibly be service pack 1 but that doesnt make much sense to me. Anyway, I welcome any comments or suggestions.

  2. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    My guess would be that you have truForm enabled...

    Disable it by going into the console (which won't be easy if you're running CAT 3.2 as then the game will hang) and type in:

    ati_npatches 0

    If you're running CAT 3.2, I'd suggest adding the line into autoexec.cfg (located in your cstrike folder)

    Hope this helps :)
  3. [SU]Mantis

    [SU]Mantis TS Rookie Topic Starter

    I put that into my console and as I suspected it said unrecognized command. So should I put that same line in my cfg now?

    Oh yeah, I also cant exit the game via windows key. If I try to go to my desktop while playing, I just get a black screen which completely locks my sysytem, I have to manually power it off and reset.

    I really appreciate the suggestion :D
  4. cslord15

    cslord15 TS Rookie Posts: 43

    I encountered the same case. Go into your Direct3D config file in the CS folder and type the command line "gl_d3dflip 1." On my Ti4200 I would be getting 80 fps and it would suddenly drop to 10-15...this helped. Get back to me and tell me if you got it fixed.
  5. DaveSylvia

    DaveSylvia TS Rookie Posts: 107

    Hi there [SU]Mantis!! Welcome! Are you running CS in OpenGL mode or in Direct3D mode? The Half-Life engine started life as the Quake 2 engine. As such, the prefered mode to use is OpenGL. If you are not currently in OpenGL mode then try switching it to that.
  6. [SU]Mantis

    [SU]Mantis TS Rookie Topic Starter

    Thanks for the welcome!
    Yeah, I'm running open gl. ATI's site is pretty much worthless when it comes to help with this matter.

    Anymore suggestions :confused:
  7. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    I know there used to be a patch you had to install to get it to work correctly. I ran it a LONG time ago, and haven't heard much about it since, so I'm not even sure where it is or what it was called. I wish I could give you more help than this, but if you search for an overflow ati cs patch in google you should be able to find it. I'll search for a bit, but feel I won't have much success.
  8. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Ok I found this....I'm not sure if it will help you because you don't have the overflow error, but who knows.

    I used to have problems with fps as well with my old school AIW, but all is better now that I have updated to 1.5, etc.
  9. [SU]Mantis

    [SU]Mantis TS Rookie Topic Starter

    Thanks, I really appreciate all the help in here... YOU GUYS ROCK!!!! Whether or not this solves my problem, it's nice to know there are people out there who are willing to take the time to help. Which I cant say for the people who took my $380 and ran like crooks
  10. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,172

    Let me know if that works....Make sure you read a little more into it before you just run it.

    If it doesn't work I will try and search for something else to try and get this thing taken care of.
  11. DaveSylvia

    DaveSylvia TS Rookie Posts: 107

    MrGaribaldi may have been on the right track in regards to Truform being enabled. There are two ways to disable it; through Counter-strike or through the driver control panel.

    The command for enabling or disabling in Counter-strike that MrGaribaldi gave is a typo. The corrected command is as follows:


    I did just try out the command to see that it works and it does. You might want to try typing in "ati_npatch 0". Let us know if find a solution.
  12. MrGaribaldi

    MrGaribaldi TechSpot Ambassador Posts: 2,512

    DaveSylvia> Thank you for correcting my typo :)
  13. DaveSylvia

    DaveSylvia TS Rookie Posts: 107

    No prob!! There are a bazillion different Half-Life console commmands; its easy to mess up a few of them.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...