Framerate drastically drops while gaming

By mousey92
Nov 13, 2013
Post New Reply
  1. About 1.5 years ago, I bought a laptop that I can use for college, but also at home for gaming. At first, framerates were not what I expected from a laptop with my specs, but I assumed it just had to do with hardware being less capable due to the fact that it's a laptop. However, I recently discovered that there was a problem with the onboard chipset, where my laptop would automatically use the onboard chipset for all graphical processes, instead of the more powerful GPU. Having that solved with nVidia settings, I now have a new problem.

    During gaming, sometimes my framerate drastically drops, from about 50-60 to 7-12 fps. This occurs randomly, even while not doing anything in-game. I have checked with the Windows Task Manager, and it does not show a significant increase in processing power, only from about 16-19% to 21-26%, which I believe should not lead to such framerate drops. I suspect this problem has something to do with thermals, since CPU temperatures can easily reach 90-95°C (194-203°F) and GPU temperatures easily reach 80-85°C (175-185°F) (measured with CoreTemp and SpeedFan)

    If this is a thermal problem, how can I fix it? Normally I'd blow out the dust, but since it's a laptop I'm not sure if that's easy/possible.
    If it's not a thermal problem, what is is? And how can I fix it?

    Laptop specs:
    Asus X5QS series
    CPU: Intel Core i7 2630QM 2.0 GHz
    GPU: nVidia GeForce GT555M
    Memory: 6 GB DDR2 RAM
    OS: Windows 7 Home Premium 64bit
    Onboard chipset: Intel HD Graphics 3000
  2. JC713

    JC713 TechSpot Evangelist Posts: 6,120   +732

    The CPU is definitely getting a bit toasty. You want it to be around 60-80 C. Open up the casing and use some compressed air to clean out the air vents.

    If that doesnt work, tell me. Also, what GPU drivers are you running? Finally, why do you have DDR2 RAM with a modern CPU? That could be part of the problem.
  3. mousey92

    mousey92 Newcomer, in training Topic Starter

    Before doing anything, I just noticed something

    The FPS drops do NOT occur when I'm charging my laptop. Could it have anything to do with voltages?
  4. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,841   +395

    NVidia GPU's tend to go into a Low power state when unplugged automatically and will stop the card from clocking up to its peak speed. As with my MSI laptop and its GT 675m, it will when unplugged drop the core clock from 820mhz down to 300 ish. You have to disable the mode to get it to run at full potential, however your battery will be drained in a matter of an hour at most while gaming.
  5. mousey92

    mousey92 Newcomer, in training Topic Starter

    Indeed, as I found out, using nVidia Inspector, the clock speed of my GPU is drastically lower when not being charged. Now the question: how do I counter this? Do I use the same nVidia Inspector to overclock or is there some other way (I'm not really a fan of overclocking)
  6. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,841   +395

    Ok heres how to turn it off, note the battery life will shoot down much faster in doing this:

    Bottom right corner, click NVidia Control Panel, go to 3D settings, scroll down till you see power management mode, then click the drop down that should say adaptive and click prefer maximum performance. That should turn it off.
  7. mousey92

    mousey92 Newcomer, in training Topic Starter

    I changed the settings, but now my laptop just shuts down immediately when I unplug the power cable...
  8. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,841   +395

    Odd, are you sure your battery is holding out well, it maybe about shot and the power usage exceeds windows limits for allowing the machine to be on (Though I doubt that because you can do it on the other setting). But to me, it still sounds like the possibility of a battery issue because that's the setting that causes the GPU to underclock itself on battery mode, you can also make sure to set your Battery mode to high performance which is done by clicking on the bottom right battery icon.
  9. mousey92

    mousey92 Newcomer, in training Topic Starter

    I was already using the high performance battery setting before I even encountered the first problem
  10. mousey92

    mousey92 Newcomer, in training Topic Starter

    Wow, the last problem (shutdown when not on power cable) was fixed by removing battery and placing it again... Sadly that reset my GPU settings...
  11. GhostRyder

    GhostRyder TechSpot Guru Posts: 1,841   +395

    Odd...Sorry I have not responded back, that's a weird problem as my computer does not do that when I set it like that...I tried all the different GPU settings and could not make it force shutdown by removing the power cable.

    It maybe a bios issue is the problem, your laptop maybe locked in the bios to set the GPU to down clock when on battery mode. I was reading some online articles talking about that, which some list no ways to override that or say with the laptop bios its not possible to change. I am trying to see if there are any alternative solutions to this, but I can see none so far. Sorry, ill keep looking and messing with my laptop to see if there is a solution.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.