Freaky APM fault

Jun 8, 2002
  1. I have XP as my main OS, 98 installed as a dual boot. When I activate APM in XP, my system turns itself off, and all those things, but 98 (and indeed BeOS) won't boot. when i deactivate APM, they will boot. However, activating APM in 98 leaves the system the same? can anyone cure this?
  2. Rick

    Rick TechSpot Staff Posts: 4,573   +65

    Do you have something against ACPI? :D

    What kind of error messages are you getting for each OS? None at all? Will they simply not boot?

    Try toggling "PnP OS" (or equivelent option) and APM on and off in the BIOS.

    Windows XP and Windows 98 handle the BIOS much differently. Windows XP should be using ACPI, not APM, unless your system is old and not compliant with current power standards. Windows 98 should feel at home with APM enbled, since it does not fully support the ACPI standard (But it should work either way).

    BeOS.. Well, I don't know much about. ACPI is a global standard used in a number of operating systems though, and should be used (if it works of course).
  3. MYOB

    MYOB TS Rookie Topic Starter Posts: 492

    I can't find ACPI in XP, only APM. I'll try the bios later
  4. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    I can say something about power management + BeOS:
    It doesn't work with these new motherboards. If you want to use BeOS with APM/ACPI enabled, you need to disable power management in BeOS before enabling them from BIOS.
    From ~/config/settings/kernel/drivers/kernel, set "power management" to false. Additionally, you can (and should) set "hlt" enabled there to cool down CPU when idle.
    There's also APM driver at but I can't tell if it works with your machine.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...