TechSpot

Fried PSU

By PHATMAN5050
May 30, 2002
  1. I setup a computer for a client and i bought a 350W power supply in a case. After i made sure everything was setup correctly, i flipped the switch, checked the bios to make sure everything was good, and then proceeded to install WINXP Pro. After a couple seconds of showing "Setup will now inspect your computer's hardware..." the whole system did a hard shutoff. I started to smell what smelt like some burning computer component so i immediately took the plug out of the back of the psu. I tried to turn it on again after a couple minutes and nothing happened. Luckily, i had an extra 250W power supply at my house so I exchanged them and everything works fine now. Why would a 350W power supply fry after minutes, and a 250W power supply work? It isn't a problem with too many things using power either...The computer setup is as follows:

    AMD Athlon XP 1600+
    Abit KR7A-Raid 133
    Creative Live! Platinum 5.1
    Creative 52x CDRom
    3 1/2 1.44mb Floppy
    GeForce 3 64mb
     
  2. StormBringer

    StormBringer TS Rookie Posts: 2,244

    Probably just a defective component in the PSU. Have you opened it up to see what it was that fried? If you smelled it, I would imagine there are probably black marks around the component that burnt out, probably a resistor or capacitor. It could have been a transistor or SCR though or even the primary or one of the secondaries on the transformer. It could also be as simple as the fuse, there could have been a power spike in the line. Finding the problem might help determine the cause.

    Even the best companies have a bad product slip out once in a while.

    Oh, almost forgot....I know this is simple but I thought I mention it anyway...you did have the voltage selector set correctly right?
     
  3. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,689   +395

    I don't think that would be a problem since he lives in the US and the US uses 110-120V instead of the 220-240V used elsewhere, using 220 on a 110 connection wouldn't fry it, only the other way around.
     
  4. uncleel

    uncleel TS Rookie Posts: 980

    Correct, in fact pc won't even turn on. A common prank in the office several years ago.
     
  5. PHATMAN5050

    PHATMAN5050 TS Rookie Topic Starter Posts: 593

    LoL uncleel.

    I made sure that it was set to 115 so that isn't the reason why. I dont want to take apart the psu because i'm gonna send it back to the company where i bought all of the components for the computer. Thanks for your help anyways guys!
     
  6. StormBringer

    StormBringer TS Rookie Posts: 2,244

    I didn't know he lived in the US, I've never noticed, I just wanted to cover everything.
     
  7. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +7

    Basically:

    1) This kind of incident is the kind of thing that, when happens to you like once in a giraff's *** (not often), co-workers laugh at you and call you inexperienced and stupid, you burned out a PSU, etc.... However was probably indeed caused by:

    2) Now and again you get a defective component. Lets hope its not that HDD with all of your important data on or that heat sink fan an athlon cpu.

    3) I would not use a 250 W PSU with the system you have recorded here.
     
  8. PHATMAN5050

    PHATMAN5050 TS Rookie Topic Starter Posts: 593

    yeah, i think i'm going to send back the old psu and get a new one. Hopefully the second one doesn't have the same problem...
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...