TechSpot

Front USB Ports died...Please Help!

By PaulVaine
Feb 27, 2007
  1. I have a MSI MOBO running XP,
    for at least a couple years the front USB ports have worked fine,
    I use them for a printer , camera, Cell phone, external HD's
    I have not been inside the comp
    Now out of now where they are dead...well sorta,
    They dont reconize anything I plug into them,
    However, the LED on the EXternal harddrive does still light up when plugged in yet it like all other things plugged in doesnt work not reconized,
    I built the comp but in many ways I am a novice,
    Can something overpower a USB port and blow it out?
    The rear ports built into the mobo still work,
    So what do you guys think is wrong with my front ports?
    Many thanks for help,
    Cheers,
    P.
     
  2. foozy

    foozy TS Rookie Posts: 139

    Front USB panels aren't the most well-designed part of any computer. Chances are you just wiggled something loose, just regular wear and tear. Might I suggest grabbing a USB hub? They make a few models that take up two rear ports and provide four on the end of a line - I usually have mine sitting on top of my case.
     
  3. rrychlowski

    rrychlowski TS Rookie

    Lots of motherboards also have extra USB ports on the board. You might try moving the plug going to the front of your case to one of these exta ports. If it works you know the USB port is fried. If it doesn't its the USB plug on the case.
     
  4. PaulVaine

    PaulVaine TS Rookie Topic Starter

    Thanks for the reply,
    So you are saying that you can fry a port on the mobo?
    What would do that?
    I will try what you suggested,
    P.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...