TechSpot

Front usb ports not appearing

By jack15
Dec 29, 2013
Post New Reply
  1. I recently change my motherboard. since then front usb ports are not working. I searched them in device manager but there are only 4 usb root hub are desplaying which are of backside. front side ports are not showing in device manager. I open cabinate and desconnect and reconnect cable into front usb ports. but its still not working. is there wrong connection on motherboard ? plz help.
     
  2. hopgop1

    hopgop1 TS Enthusiast Posts: 192   +22

    Check the manual again against how you have plugged the front panel ports into the header, the old motherboard and the new one are most likely not the same as how the front panel ports on the old one are.
     
  3. mailpup

    mailpup TS Special Forces Posts: 8,506   +238

    When you changed the motherboard, did you install all of the drivers for that motherboard? If you haven't already, you should uninstall any of the drivers for the old motherboard.
     
  4. jack15

    jack15 TS Rookie Topic Starter

    I don't know anything about motherboard or header. I changed my motherboard from technician. he told me to bring it back to him but I decided to do it myself with ur help.
     
  5. hopgop1

    hopgop1 TS Enthusiast Posts: 192   +22

    Are the ports USB 3 or USB 2 at the front of the case?
     
  6. Benmar

    Benmar TS Rookie Posts: 53

    It could be the cable of the usb is not align properly according to is sequence,example the positive charge and negative charge should be in correct possition
     

    Attached Files:



Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.