game cannot be displayed after installing a new agp vga card.

By san613
Apr 11, 2005
  1. hi guys,

    after i installed a vga card into my pc, my games which previously was working properly suddenly not accessible as the monitor is not displaying the image. i supposed the monitor is not displaying the image because i can hear the sound of the game and the interaction action sound effects as well when i press ESC, arrow key etc. and i more detail that i observe is the the indicator light of my monitor goes into standby mode whenever i load the games.

    the game i was playing with my onboard vga is Kult: Heretic Kingdoms with the path 1.3 installed. i have uninstalled the onboard vga drivers and the agp vga card drivers and installed back the agp vga drivers. I have also reinstalled the game but the result still the same. i have visited nvidia's site and make some adjustment to the bios which i have flashed with the most recent bios as well.

    the adjustment i made to the bios were
    1. pci latency timer: from 32 to 128
    2. primary vga card: from onboard to agp
    3. onboard vga card: from enable to disable
    4. graphics aperture size: from 32 to 128
    5. onboard vga shared memory: from 64 to 4 (4 is the lowest by the way)

    I have also tried to different refresh rate that my monitor can support such as 60 HZ, 70 Hz, etc. i have search the internet for similar problem but could not find any that fit my situation. please help me.


    Mainboard: ASUS TeK P4SGX-MX
    CPU: Intel P4 1.8 GHz (PGA478)
    BIOS: Award Software Inc, ASUS P4SGX-MX ACPI BIOS REV 1005
    VGA: MSI MS-StarForce GeForce4 MX 4000
    Monitor: plug and play monitor
    CDROM: Samsung CD-ROM SC-152A 52X
    Memory: 256 MB DDR
    OS: XP Pro, version 2002, service pack 2.
    HardDisk: 30G
  2. bushwhacker

    bushwhacker TechSpot Chancellor Posts: 783

    Hello and welcome to Techspot!

    You cannot change the AGP Latency, just leave as it is! Disable the onboard VGA, disable the vga shared memory, but you can set your agp aperture size in 256 for optimal perfomance!

    You should have the nVIDIA FORCEWARE v56.72 from the link in my signature for better solution and disable that two desktop in your GeForce4 MX 4000 tab.

    to be clear, right click on your desktop and select properties/settings/advanced/GeForce4 MX 4000 tab. find your desktop and select as ONE monitor not television or two monitors.

    Install specific driver for your monitor will great help.


    p.s. you should have microsoft directx 9.0b for most of games
  3. san613

    san613 TS Rookie Topic Starter

    thanks lucan.

    i have try to installed the driver that you recommended. somehow i could not locate the place to disable the two desktops. but however, after some try and error, i have managed to solve the problem. apparently, my desktop was not in the correct resolution that the game required. after changing the resolution and now i am playing happily now.

    thanks guys.

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...