Geforce 5500 256mb

By Zeltek
Aug 5, 2005
  1. Hey guys a friend of mine just purchased a Geforce 5500 256mb version, and hes getting no more than 13 fps on doom 3, EVEN at the absolute lowest settigns, with EVERYTHING turned off, even with the latest drivers and patch. Every site I see suggest that he should be running at 8x6, high settings, and at 30-40 fps. hes running an AMD Athlon XP 2700+, 512mb ram, Xp home.
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    let's hear detailed specs on that card, including the actual clock speeds and memory bus width. you can pick up a cheap fx5500 with 256mb of ram these days, but to turn a profit the companies will use lower quality parts that run at lower clock speeds, and most use a relativelwy narrow 64bit memory bus.
  3. Zeltek

    Zeltek TS Rookie Topic Starter

  4. zephead

    zephead TechSpot Paladin Posts: 1,569

    don't expect that $60 rosewill card to play doom3 as well as you thought i would be. it's a cheap low end card.
  5. Zeltek

    Zeltek TS Rookie Topic Starter


    I really dont think you quite get it, really people Ive talked to really think this should run at med-high. I mean its auto configure is set to that. And if my old 4200 128mb can run it a med settings... 10-14fps with everything turned off? Hell a geforce 3 can run it ALOT faster.
  6. DonNagual

    DonNagual TechSpot Ambassador Posts: 2,404

    What screen size are you running doom3 at? This makes a HUGE difference.

    I am not surprised at all that with that card your friend has the game is running poorly. The 128Mb 9800pro card has better clock rates than that plus it is 256bit interface. That card your friend has is pretty low end for today's games, I'd have to agree with zephead.
  7. wirm

    wirm TS Rookie Posts: 64

    What are his computer specs?

    You mentioned that your computer has a lower end video card, but do you have a higher end computer?
  8. Zeltek

    Zeltek TS Rookie Topic Starter

    Hes running it at 6x4, with absolutely everything turned off. Hes running an Athlon XP 2700+ 512mb ram. But it should still run pretty well, Im mean really, my 4200 ran it WELL at med settings with a 2100+, and 512mb of ram.

    And Nvidia cards have always kicked the crap out of ati as for as OGL comes, a 6600 beats the x800 in all doom 3 tests. So tis not suprise that the 9800 wasnt doiong so hot.

    And I dont know whats wrong with your 6800, but Im running it at Ultra settings(Minus AA) 12x10, and Im running a 6600gt. 1gb Corsair, and a Amd 64 3000+.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...