TechSpot

GeForce 6600 GT Nvidia Problem in Games

By Doc Holliday
Sep 3, 2005
  1. Hey all.

    I'm hoping someone can help me with a problem occuring during certain games. I'll be able to access main menus of the games, but when i try to actually play them, my screen goes black and the game doesn't respond. This happened with Worms Armageddon and Diablo 2.

    My graphics card is GeForce 6600 GT nVIDIA 128MB DDR3

    Is anyone else experiencing similar problems?

    If you can think of anything worth trying please tell me! I really have no idea what to do. If you need any more information just ask.

    Thanks so much
     
  2. Wotrop

    Wotrop TS Rookie Posts: 112

    I have the same problem.

    I have the same thing. When i play BF2 or RTCW on my 6200tc. i can go to the menues and stuff but when i try to play the game the screen goes blach and un responsive. This only happens in windows 2000 for BF2.

    This is turning me off of Nvidia. They make good cards but they never work right. :(
     
  3. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 1,382

    Hello! Welcome to TechSpot

    What version of nVidia drivers are you guys runnin?
     
  4. Wotrop

    Wotrop TS Rookie Posts: 112

    well i use the one from nvidia's web site. i formatted my pc yesterday. so the latest one
     
  5. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 1,382

    Cool!
    We need the platform or system info you have this card in.
    It'll help us to help you..
    Get a copy of everest home,if you need, it will give you tons of info about your system, and it's free...
    G'Luck
     
  6. Wotrop

    Wotrop TS Rookie Posts: 112

    Doc aint talking much, but i am running win XP pro. Athlon 64 3200+ wichester on an asus A8V-E deluxe with 512 megs of kingston pc 3200 ram and nvidia 6200tc vid card. 450w power suply. Connected to my wall. :p

    Hope that helps.
     
  7. SOcRatEs

    SOcRatEs TechSpot Paladin Posts: 1,382

    you have northbridge southbridge Via chipset,
    win2k or win xp?
    Try this link to via hyperion 500a pro read through see which driver is right for you.
    I hope this helps...
    G'Luck
     
  8. Wotrop

    Wotrop TS Rookie Posts: 112

    Well that fixed my problem thanx. but will doc respond to his own thread is somthing that we need to be concerned about, :chef:
     
  9. wiscountryboy

    wiscountryboy TS Rookie Posts: 128

    power issue

    i had that problem with medal of honor pacific assualt...then i realized that i had forgotten to plug in the power connector to the card, give that try
     
  10. Wotrop

    Wotrop TS Rookie Posts: 112

    power into card? never herda that. The only thing i plug in is my monitor. Do faster cards need more pwer that cant be suplied? I dun care
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.