GeForce4 MX and Forceware 66.93

By NeoChaosX
Jan 6, 2005
Topic Status:
Not open for further replies.
  1. Little help needed. My family's PC has a GF4MX, and my brother recently got Half-Life 2, so I upgraded the video drivers to 66.93 for max performance. Now we're getting a strange problem. When my brother starts any game, it goes into software acceleration mode. If he tried to change it to hardware aceeleration, he gets an error that hardware mode isn't supported. When I went to the Advanced Properties in the Display panel, there was no nVidia tab! But I checked Device Manager, and the drivers are still installed. I've tried uninstalling and reinstalling the drivers, and using Driver Cleaner to clear previous drivers out of the system, but we still can't get 3D acceleration to work, or an nVidia tab to appear. Anybody with insight on why it's happening and how to fix it?
  2. karlt78

    karlt78 Newcomer, in training

    Is this just this Halflife 2 or is it with all 3D accelerated games??

    Also, is your display adapter recognised in device manager as a Geforce 4 MX?
  3. NeoChaosX

    NeoChaosX Newcomer, in training Topic Starter

    All games - he can't even play HL1 or classic CS because of this. And yeah, the device manager recognizes the card as a GF4MX.
  4. gznhustlers

    gznhustlers Newcomer, in training

    ge force

    Hi sorry just trying to solve my own problem with geforce!!! how do u clear all old drivers from your hard drive then I rashly installed my Geforce card and I cant play any games at all keep getting errors coming up whe I start any games!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.