Generic Host Process for Win32 Services Error

By hoah
Mar 6, 2005
  1. Hello, today, I have de-installed an Avast Antivirus Home, and istalled a new one (Norton Antivirus Pro 2004). Everything went OK, but since then, after every restart of my pc, I get a message that the Generic Host Process for Win32 Services found an error and has to be closed...
    So what does it mean? Have I done something wrong? Or what do I have to do to get rid of this? Please, HELP... Thanks!
    Jan, Prague
  2. the__godfather

    the__godfather TS Rookie

    Fix to problem

    There is a known issue for win32 services(svchost.exe) to play up. Furthermore the problem is linked with Winsock. Firsly unintsall your antivirus program and restart your computer. Download the patch from Microsoft first (KB 894391);en-us;894391

    You will also need the winsock repairer which is available at this link.

    Firstly install the microsoft patch, restart your computer then run the winsock repairer.Please download the appropriate files for your operating systems. Before applying these patches you should be aware that some of your network settings may be reset. This problem occurs seemingly randomly. To minimise the impact, make copies of your hosts file, socks configuration and note your IP settings.

    Once all this is done re-install your antivirus and update your virus definitions.

    Make sure you restart your computer everytime you are asked to (generally after every patch) otherwise something can go wrong.

    Regards, Matt
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Do NOT reinstall that Norton crap!
    go to and get the free AVG7 instead. Much better, smaller and faster.
  4. the__godfather

    the__godfather TS Rookie


    If you have bought your Norton antivirus use it don't put it to waste, but honestly there is a lot better out there, even free ones. I have always been a fan of NOD32 simply it is a good solution (quick and thorough), but Avg also doesn't do a bad job if you don't want to buy an antivirus program.
  5. KiyoshiJoz

    KiyoshiJoz TS Rookie

    ....hrmm i haf a prob regarding dis prob..

    it happened after my avast antivirus updated today......bassically when im online for like 30 minutes or so...i get a msg sayin generic host processor win32 or sth like dat..n when i clicked dont toolbar became sumthing like a windows 98 program..for like 10 seccs or so...n then it kicks me offline....when i click on my broadband to reconnect...the program flashed twice like super fast n dissapears....n i cant reconnect unless i reboot....its happening randomly even now..ive tried ur solution of winsock repair...but ur site isnt i got another winsock repair from nod32...nnn it worked for a while.....n then it happened again....plz help...its annoying...thx
  6. the__godfather

    the__godfather TS Rookie

    Answers answers


    The error you are getting is actually a part of a virus, some sort of worm, cant think of the name at the moment. But all that aside the solution to fix your problem is a hyperlink away. The security bulliten MS06-040 will resolve this issue. There is a patch you must download. Apply It and all should be good.

    Any further queries please let me know

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...