TechSpot

Genius Speakers

By InFlamessss
Apr 8, 2009
  1. I just plugged in my speakers with everything, but for some reason they only act as a normal set of speakers. The front two work but that's it. My subwoofer, rear speakers, and even the center don't emit any sound at all. I've changed all the settings on my comp to support the 5.1 surround sound but they still won't work. Any suggestions?

    Can you at least tell me a site that can solve this problem.

    Thnx in advance.
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Are you using an audio card or on-board sound? What are your computer's specs?
     
  3. InFlamessss

    InFlamessss TS Rookie Topic Starter

    I had a Genious 5.1 Audio Card that came with my speakers and was working on my old pc but when i plug my speakers now they won't even work. When i plug them on the on-board sound card only 2 of them work.
    Could it be that my genious sound card is broken?
     
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    What is you new computer? Make and model? Operating system, Windows XP, Vista?
     
  5. InFlamessss

    InFlamessss TS Rookie Topic Starter

    XP
    Pentium IV, 3.4 CPU, 1gb Ram

    Man i need help. I don't really know a lot about computers.
     
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    HP, Compaq, Gateway, eMachines or Dell? Model number?
     
  7. InFlamessss

    InFlamessss TS Rookie Topic Starter

    ECS
    Model No: 945P/PL-A
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...