TechSpot

gentoo boot failure (hard drive not mounted properly)

By winglet
May 7, 2005
Topic Status:
Not open for further replies.
  1. Hi!

    I've been pretty frantic about a problem i've been having. I have a gentoo file server at home and I had given it a reboot. I had typed : 'init 0' and while the server was shutting down, it gave me some module dependency errors so I hit the power button and gave it a hard boot. Now when I reboot it back up, it tells me that my hdb1 was not properly unmounted, it tries to fix it...and then crashes shortly after that.

    Is there anyway I can retrive the data on that hard drive? All help would be greatly appreciated.
     
  2. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,916   +9

    What's the error when it crashes?

    Boot from CD to console (I assume Gentoo's disc has a "rescue" console) and do fsck /dev/hdb1.
     
  3. Justin

    Justin TS Rookie Posts: 1,595

    What filesystem is /boot ?

    If you have the filesystem specified incorrectly in fstab and you try to fsck it, it may try to use the wrong tool and die. If you boot from the gentoo CD or a knoppix cd, run fsck.[filesystemtype] on the partition in question.

    Also, you should not be mounting /boot unless you need to update the kernel or makes changes to grub.conf . It's better to leave /boot unmounted, in which case you'll never have to worry about a hard shutdown causing damage to it.

    If you are using reiserfs for boot, make sure the notail option is added under mount options in fstab.
     
  4. winglet

    winglet TS Rookie Topic Starter Posts: 29

    I'm not sure what filesystem it is

    do you mean hda1, hda2, etc.?

    Anyways, I ran fsck /dev/hda1 and it returns:
    fsck 1.35 (28-Feb-2004)
    e2fsck 1.35 (28-Feb-2004)
    /dev/hda1: clean, 38/10040 files, 8052/40128 blocks

    Then I ran fsck /dev/hda2 and it returns:
    fsck 1.35 (28-Feb-2004)
    fsck: fsck.swap: not found
    fsck: Error 2 while executing fsck.swap for /dev/hda2

    Then I ran fsck /dev/hda3 and it returns:
    fsck 1.35 (28-Feb-2004)
    e2fsck 1.35 (28-Feb-2004)
    Couldn't find ext2 superblock, trying backup blocks...
    ext3 recovery flag clear but journal has data
    Recovery flag not set in backup superblock, so running journal anyway
    /dev/hda3: recovering journal
    Pass 1: Checking inodes, blocks, and sizes


    After this, it seems to freeze and nothing more seems to happen.....

    any thoughts?
     
  5. winglet

    winglet TS Rookie Topic Starter Posts: 29

    actually, it keeps going....

    and then it asks me

    Free inodes count wrong for group #*some number (*some number, counted = *some number)

    and it keeps asking me to fix
    so I have just been pushing y
     
  6. winglet

    winglet TS Rookie Topic Starter Posts: 29

    Okay, I was able to fsck all my hard drives...

    however, when I boot up my server now, it tells me that I have to be in root to run everything

    so I look around to make sure all my files are still on there

    login as root
    and then type reboot

    When my server boots up again, it says hdb1 was not cleanly unmounted again! And it does a check forced

    then freezes again....
     
  7. winglet

    winglet TS Rookie Topic Starter Posts: 29

    hmmm

    I tried starting the ssh daemon and it gave me an ERROR: must be root to run init scripts

    BUT, I AMM in root

    so I try typing su to try and get into root again and it gives me a segmentation fault....

    any ideas?
     
  8. winglet

    winglet TS Rookie Topic Starter Posts: 29

    grr
    there's just too many problems

    I'm just gonna transfer all my files

    Then reinstall gentoo

    Any tips/tricks for what I can do when setting up my home server?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.