TechSpot

getting 10fps with World of Warcraft with my Radeon 9550 :(

By stevenazari
Aug 31, 2006
  1. Guys Im not sure why Im getting this, but I was having problems installing the graphics card,

    I had to set the aperture size to 256 even though its only a 128mb card :S

    When Im playing wow the frame rate variest depending on what Im looking at :S no idea how to resolve - I've tweaked around in the settings of wow but to no prevail :S
     
  2. MetalX

    MetalX TechSpot Chancellor Posts: 1,388

    Can you post your other system specs like CPU and memory and everything you know? We might be able to help you if you do.
     
  3. stevenazari

    stevenazari TS Rookie Topic Starter Posts: 44

    sure spec is in my profile too.

    Intel Pentium 4 2.8
    2GB Corsair DDR RAM
    120GB IDE Hard Drive
    Sound Blaster X-Fi
    2MB Broadband over wireless network (average ping of 86)

    I used systemrequirementslab.com to check if my would be fine, it said my gfx card is fine on 1 page and checking the failed it said my gfx card wasnt good enough :S so it kinda contradicts itself.....
     
  4. korrupt

    korrupt TS Rookie Posts: 716

    Did you say you just started playing WoW when it happened? or have you played WoW before with good fps?

    Regards,

    Korrupt
     
  5. stevenazari

    stevenazari TS Rookie Topic Starter Posts: 44

    I've been playing wow for a while now, just never had a good fps....

    Im now using this radeon 9550 because it is better than my old Nvidia 440 mx :p but Im getting the same crappy results....
     
  6. Rayss523

    Rayss523 TS Enthusiast Posts: 102

    did you uninstall the old video drives and then install the new ones?
     
  7. NFSFAN

    NFSFAN TS Rookie Posts: 245

    Maybe your Radeon 9550 can't handle WOW. Try a GeForce 6600 GT or Radeon 800 GTO
     
  8. stevenazari

    stevenazari TS Rookie Topic Starter Posts: 44

    its ok now :) turns out turning everything on full power worsen's performance (stupid me for forgetting that) but yeah works fine now - 50fps average :p
     
  9. Cgf

    Cgf TS Rookie

    How do you take things everything off of full power?
     
  10. stevenazari

    stevenazari TS Rookie Topic Starter Posts: 44

    if your using ati's catalyst you go through the 3d settings, alot of "application controlled" just check that :p or turn the settings DOWN
     
  11. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,715   +397

    I'm sure he meant having all the settings on high. I've not played that game but I bet there are anti aliasing settings, and detail settings, resolution setting, and stuff like that. Having those all turned up really taxes the card.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...