TechSpot

Good Ol' x700

By skarex
Mar 5, 2007
  1. Some time ago i posted bout trouble with my Mobility Radeon X700, i had an issue with sound and video sync, and especially with my apps such as games and while playing movies, buffering every few seconds not letting me really do anything. I was told to do a "clean install", if i remember correctly, download latest drivers, resintall hardware, and pretty much anything simple enough for someone of my knowledge to apply. So after all that nothing worked so i just hid the laptop away for sometime to forget my frustration. Now that i no longer have my desktop im back to my laptop and hoping that by now someone can help me with relative ease. I have been told that my video card had compability problems with the chipset, but i dont know how to go about that. I've also paid close attention to CPU Usage and it goes wild all the time... from 100% to 5ish% back and forth rapidly. I don't think its overheating, and i'm not running anything too drastic, at most World of Warcraft, which l can run at max or low settings, but still buffers, so i cant play effectively.

    SPECS: (Not sure you need all that, but doesn't hurt.)
    System Model: MS-1029
    BIOS: BIOS Version : A1029AE5 V2.30 07/15/05
    Processor: AMD Turion(tm) 64 Mobile Technology MT-34, ~1.8GHz
    Memory: 1022MB RAM
    Card name: MOBILITY RADEON X700 (Microsoft Corporation - WDDM)
    Manufacturer: ATI Technologies Inc.
    Chip type:
    DAC type: Internal DAC(400MHz)

    I looked around for a similar post of existed, no luck, if there already exists a solution, pls direct me to it.
    Ty for your help in advanced =).
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.