TechSpot

Google Chrome gives me security errors all the time

By Joshua Minett
Oct 17, 2015
Post New Reply
  1. So I am connected via ethernet to a school network that's filtered by Barracuda. Not a problem. But like 70% of websites I try to visit (these are not sites that are blocked by Barracuda) kee showing up on Chrome as "Invalid security certificate," and similar stuff like that. I already know that it's because Barracuda is intercepting my internet requests. All I want is for Chrome to stop keeping me from accessing those sites due to the security errors. Is there any way to make Chrome ignore security errors? I'm tired of getting blocked from sites that are totally normal, like yahoo.com. Any help is appreciated!

    I am running Windows 10 Home, Chrome 46.0.2490.71 m (newest version as of writing this), and updated java.
    upload_2015-10-17_14-10-16.png upload_2015-10-17_14-10-16.png
     
  2. learninmypc

    learninmypc TS Evangelist Posts: 6,601   +335

    I'm ignorant on this but I'd say you need to talk to the school IT people. They have certain websites blocked for a reason.
     
  3. Joshua Minett

    Joshua Minett TS Enthusiast Topic Starter Posts: 64

    The site is only being blocked by Chrome, not the filter. Talking to the school would do nothing.
     
  4. learninmypc

    learninmypc TS Evangelist Posts: 6,601   +335

    What website you trying to get to?
     
  5. Joshua Minett

    Joshua Minett TS Enthusiast Topic Starter Posts: 64

  6. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,556   +2,900

    The only time I have had issues with security certificates was when the time/date on my machine was wrong.
     
  7. Joshua Minett

    Joshua Minett TS Enthusiast Topic Starter Posts: 64

    Both time and date are accurate; set to correct time zone and internet time.
     
  8. learninmypc

    learninmypc TS Evangelist Posts: 6,601   +335

  9. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,556   +2,900

    After thinking a bit, it looks as if your network type might be set to home public instead of public private.
     
    Last edited: Oct 17, 2015
  10. learninmypc

    learninmypc TS Evangelist Posts: 6,601   +335

  11. Joshua Minett

    Joshua Minett TS Enthusiast Topic Starter Posts: 64

    This is the current setting:
    upload_2015-10-17_19-37-29.png
     
  12. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,556   +2,900

    I edited my last comment after refreshing my memory on the terms.

    There it is. Your connection is public. You need to change it to private because Chrome is looking for a private network.

    I just did so myself by going through the HomeGroup Troubleshooter.
     
  13. Joshua Minett

    Joshua Minett TS Enthusiast Topic Starter Posts: 64

    Ok, how do I do that? because the screen I showed you in my last comment offers no options for changing that setting. Clicking the connection did nothing.
     
  14. cliffordcooley

    cliffordcooley TS Guardian Fighter Posts: 8,556   +2,900

    It is the HomeGroup option to the left at the bottom. And on that page there should be the option to start Troubleshooting. It might be confusing as it goes through all the steps including Network Troubleshooting. But if it finds anything it will give a solution to fix the issue.
     
  15. Joshua Minett

    Joshua Minett TS Enthusiast Topic Starter Posts: 64

    That did it. Thanks cliffordcooley!
     
    cliffordcooley likes this.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...