google doesn't work

By rkhd101
Jun 10, 2007
  1. I can't use google at all. If a website uses google for a search engine, I can't navigate the site. My computer will just sit with a blank screen and never displays anything involving google. Is there some sort of fix for this? HELP ME!!!
  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Try stopping any toolbars you are running - there is a possible conflict with MS updates especially with the Yahoo toolbar. Also reset all your security settings to default.
  3. tomrca

    tomrca TS Rookie Posts: 1,000

    on your IE browser click tools>internet options>lan settings. and tick box, auto detect settings. see if that works for you.
    you can also try shutting down your firewall for a few seconds then try opening google as it could be doing the blocking.

    you could also run scan for bugs n stuff. if you do go toTHIS LOCATION and follow instructions
  4. jobeard

    jobeard TS Ambassador Posts: 9,156   +598

    try another browser (like Firefox) to see if it's a browser issue vs. a system networking issue.
  5. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Go and read this thread HERE and post a HJT log as an attachment into this thread.

    Regards Howard :wave: :wave:
  6. rkhd101

    rkhd101 TS Rookie Topic Starter

    another browser

    i tried firefox and it seemed to fix some things, but not the google issue. thank you for your suggestion!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...