TechSpot

Got Audio No Video HELP!

By AmGreen14
Nov 26, 2007
  1. Hey all,
    I'm a total noobie (in all aspects) and heres my problem:
    I try to play DVDs, .avi or .wmv and no matter which program I use I get Audio but no video. I tried to convert the videos but even the video converter says something about no access to the output?? so it cant play the video to convert it.
    I checked the individual videos to make sure they had all the codecs or whatever and they're fine. I've got a Sony Vaio laptop with Windows XP thats hooked up to a monitor cuz we dropped it a few weeks ago and the screen went out. Going through troubleshooting, everything says that video is running fine, but honestly I dont really know where to check. Oh and video online plays fine too (youtube etc.) If you have an answer for me please break it down as much as possible. THANKS!!!
    - super noob and recent tech addict in CA
     
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    "I've got a Sony Vaio laptop with Windows XP thats hooked up to an external monitor cuz we dropped it a few weeks ago and the screen went out"...

    Was the DVD video working before the laptop was dropped?
     
  3. AmGreen14

    AmGreen14 TS Rookie Topic Starter

    yup

    yuppers. and its weird cuz i found a home movie from a long time ago that worked but another one from recently that didnt. cant find that movie anymore of course to see what type of file it was.....
     
  4. Gavin_Capacitor

    Gavin_Capacitor TS Rookie Posts: 47

    your player might be messed up, try something like windows media player classic with the k-lite mega pack (choose #5, 'lots of stuff'). Also, does the player not show the video as in it just shows black at the correct resolution, or does it show nothing (as if a music file was playing)?
     
  5. jeff968

    jeff968 TS Rookie

    You need to install a dvd codec. Install a dvd player program like power dvd.
     
  6. AmGreen14

    AmGreen14 TS Rookie Topic Starter

    I downloaded a bunch of different media players but they all do the same thing, the screen is black at the correct resolution with sound. I transfered the videos to a friends computer and they all play fine.
     
  7. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    You are missing a codec file that is used by all the Media players you have tried. Until you find and install that codec, you will continue to have sound, but no video. Try what Gavin_Capacitor has posted
     
  8. AmGreen14

    AmGreen14 TS Rookie Topic Starter

    I went to codecguide.com to check for that k-lite player and I'm not sure what he means by (choose #5)? Should I be looking somewhere else?
     
  9. AmGreen14

    AmGreen14 TS Rookie Topic Starter

    It didnt work! I downloaded MPC K-kite mega pack and the movies still play black! What tha-!? I went through the help section and did everything it said but still no go!
     
  10. AmGreen14

    AmGreen14 TS Rookie Topic Starter

    if this helps figure it out; when I try to record movies with PSP Video Express the error message says: can not open output file. access denied.
     
  11. jkiddmagic

    jkiddmagic TS Rookie

    I would try downloading DivX Video player and the Divx Codec package. It works like a charm with all types of video.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...