Graphics card died, needs replacement

By patton
Oct 31, 2009
  1. Hello all,

    My Nvidia 8800 GTX 768mb card died this past week so now i need to replace it. My game of choice is EQ2 which I play at high seetings sometimes duel boxing toons on the same pc.

    I run duel monitors one is 24" and the other is 21"

    I have a 1000w power supply
    Intel P4 duel core 2.66
    Raptor 10k rpm 150gig hard drive
    mother board is Asus P5N-E SLI
    memory uh if i remember correctly is 833speed 3gigs
    windows XP Home

    I want a card that can easly handle duel monitors at high resoulotion plus high gaming settings EQ2 demands a lot so want something that will last for a while. this time around I do not plan on paying $550 like i did for the 8800GTX when it came out. So something between say a $100 - $300+

    Thanks for your help
  2. XOR

    XOR TS Rookie Posts: 25

    I'd go for a 5850 or 5870 if your budget allows for it, or a GTX 260 which can be found for 170-200.
    And FFS get rid of that P4 and get a Core2 otherwise you'll be cpu limited.

    Not sure if linking to other forums is allowed but you could always try this
  3. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 1,672   +9

  4. patton

    patton TS Rookie Topic Starter

    Thanks for the feedback so far. I would preffer to stick with Nvidia primarly because EQ2 is based off Nvidia design and thats what my pc is primarly for.

    I want to stay within $100 to $300 or so, have been hearing good things about the Nvidia 200 series cards any thoughts there?
  5. Alster37

    Alster37 TS Maniac Posts: 290

    in the long run i'd advise a 5850 even though you want to stick with nvidia because this series of cards are making a "revolution" in terms of value and performance.

    hope this helps :approve:
  6. patton

    patton TS Rookie Topic Starter

    Here are the exact specs of my pc finally found my paperwork:

    If I do end up getting a new CPU while I'm at it what do I need to do in order to make sure it works well with my current motherboard?

    1000watt--Thermaltake toughpower W0132RU power supply quad sli rdy
    processor (intl core 2 duo processor E6700 (2x 2.66ghz/4mb L2 cache/1066fsb)
    motherboard (MSI P6N SLI-F nForce 650i SLI chipset w/7.1 sound, GB lan, s-ata usb 2.0 IEE) <-------this is strange because the book i have for my motherboard says P5n-E SLI....humm
    memory (2048MB [1024mb x2] DDR2-800 PC6400 memory module corsair xms2 xtreme <-----------I added another 1gig chip later on
    video card (nvidia geforce 8800gtx 768mb w/dvi + tv out
    hard drive Serial ATA-150, 10,000 rpm WD raptor wd1500adfd
    windows XP Home
  7. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 1,672   +9

    Well that processor is a pretty decent one. If you plan on sticking with it then just get the Radeon HD 5850.
  8. patton

    patton TS Rookie Topic Starter

    Well it seems every where I go folks are recommending the AMD 5850 card as the card of choice right now. So think I am leaning that way, while I am at it I would also like to upgrade my CPU. Current CPU is processor (intl core 2 duo processor E6700 (2x 2.66ghz/4mb L2

    Have had some suggest this Intel Core2 Duo E7500 Wolfdale 2.93GHz

    Would I see a nice performance improvment with the new card and that CPU vs my old card and CPU?
  9. Tha General

    Tha General TechSpot Paladin Posts: 1,106

    QUESTION, why did your card die, were you oc?
  10. patton

    patton TS Rookie Topic Starter

    Have no idea why it died, one day it just started to freak out.

    My problems the sunday before last out of know where, I was on my warlock in a DD group and bam my graphics go crazy, colors start going bezerk, almost like a mosaic of colors and such flashing almost like the game was still running in the back ground i just couldn't make out any image. Both my screens would flicker from time to time, and the color's would bleed over to one another. So I rebooted the pc and chalked it up to just bad luck, then rejoined the group and bam like 5 min later it does the same thing. So I reboot yet again and rejoin and bam a few min later it does it again. This time around I am really upset and decide to log into a diffrent toon and play the game. So I logg into a diffrent toon and play the game for a few hours without any problems...

    Tuesday comes along and I am playing the game again thinking it was just a fluke from the day before. But after about a hour or so bam it happens again. So I reboot and log back in rejoin the raid and play the rest of the night without any problems. The next day comes along and i am in a group in EA and it happens to me again (mind you it always seems to happen with i am on warlock) someone in group said they had the same card I do (8800 GTX 768MB) and they had the same problem. Hwoever once they updated the drivers the problem went away. So I thought oh ok i will do that tomorrow. So I play the game the rest of the night with no problems running all over the place changing in and out of diffrent toons and zones.

    So last night comes along and before raid i update the GPU drivers and log into game and start to call home and bam the game does the same thing. So I reboot and log back in and with in 30 secs it does the same thing. I reboot yet again and now i can't even get the XP log in screen to appear. I start to get strange white lines, dashes and such on my screen before the windows log in screen even comes up. After a few more reboots i get logged back into XP and the game and with in a min or two it does it to me again. So I do a system restore thinking man that new driver really made things worse. Before last night the only time i had problems was in game on my warlock now its starting to do it to me even while i am sitting at desktop. Well after a while I was able to get back to desktop and I check my chipset driver and BIOS version and noticed there is a new bios version that was released this week. So I flash the bios and reboot log into game and it does it to me again , so I reboot update graphics drivers and reboot log into the game and it seems to be fine. I leave the game logged in for @ 45+ min and zone a few times, cast a few spells, buffs run around ect...trying to get it to do the samething and it seems to be fine.

    Then i open IE on my 2nd monitor and with in a few secs I get the " EQ2 has encountered a error and must shut down" I click ok and it drops me to desk top. By this time its after 11pm and I have beem messing with this crap for the most part since @ 6:45pm so i just shut the pc down and go to bed.

    The next day I get home open the case up and clean it out and check all connections. Fire it back up and still the same just now its happening all the time. Its like the problem has just gotten worse over the week. I started to post my problems on a few forums and had a friend come over and take a look to see what he thought and he also thinks its the GPU. Before it got really bad I did a disk check, memory test ect...and all were fine.
  11. XOR

    XOR TS Rookie Posts: 25

  12. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,433   +143

    Haha of course, bake it ^^.
  13. XOR

    XOR TS Rookie Posts: 25

    Worked on my Xbox 360 that had rrod
  14. patton

    patton TS Rookie Topic Starter

  15. Ritwik7

    Ritwik7 TechSpot Chancellor Posts: 1,672   +9

    Those two look great! Best of luck.
  16. klepto12

    klepto12 TechSpot Paladin Posts: 1,115   +9

    will the e8400 run in a 650i board ? also that cpu is cheaper at
  17. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,433   +143

    Yes it should...
  18. patton

    patton TS Rookie Topic Starter

    Well I got my new CPU a few days ago but sadly my graphic's card is still on back order!!

  19. patton

    patton TS Rookie Topic Starter

    Well got a notice from Amazon today about a ETA on RADEON HD 5850 1 GB DDR5 PCI Express Card ROFL!!!! According to them it will be after 12-25-09 my lord that is insane! I mean I can understand when something new comes out and is a hot item it can be a bit hard to find it in stock but 2 months!!

    And the wait contiunes sadly.

    Ended up ordering a diffrent card just to hold me over until I can get the 5850 wife was so very happy when I told
  20. red1776

    red1776 Omnipotent Ruler of the Universe Posts: 5,219   +157

    I really get the feeling that we are not getting the straight skinny on the 40nm yields, I think there is some collusion going on here.
  21. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,433   +143

    Most certainly...
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...