TechSpot

Graphics card help

By Susuka
Feb 14, 2009
  1. Hi!
    Please could you give me a hand with my problem;
    Recently my graphics card died so i decided to buy a new GeForce 7300 Gt Agp card. But as you all know i must uninstall all the old graphics card drivers and then install the new graphics card drivers.

    This is where my problem occurs, i dont have a display on my monitor to uninstall the old drivers because my old graphics card died, i installed the new GeForce card into my agp slot but i do not have a display with that in either, i think it is beause i have to uninstall the old drivers.

    I do not have any onboard graphics on my mobo.

    Is there anyway to uninstall the old drivers?

    I'd really apreshiate any help, thanks.
     
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,704   +397

    Does anything display at any point? If you aren't even getting your initial POST screen then something else is the issue.

    If you lose it after Windows starts to load you should be pressing F8 like you are trying to get into safe mode, once the menu comes up choose VGA mode. Then you can uninstall/install drivers from there, reboot and things should be working.
     
  3. Susuka

    Susuka TS Rookie Topic Starter

    Thanks for your reply;
    The screen only says ''No signal input''
     
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,704   +397

    Does your motherboard have an onboard video port?
     
  5. Susuka

    Susuka TS Rookie Topic Starter

    Sadly not no.
    Do you think i will have to buy a new mobo?
     
  6. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,704   +397

    At this point I don't know for sure what the problem would be.

    Possibly:
    Dead AGP Slot
    Bad VGA/DVI cable
    Bad Monitor

    Can you test the monitor on another system?

    Edit: I did just see you said no onboard earlier, so apologies for missing that.
    The reason it isn't a driver issue like you originally thought is because if it was there would have been something displayed before Windows begins to load on boot.
     
  7. Susuka

    Susuka TS Rookie Topic Starter

    Yes i tested the monitor earlier on another system i also tested my friends monitor with my computer with another VGA cable too! But still no display.

    Would it be possible that my computer is rejecting the new graphics card because it has the old drivers installed?
     
  8. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,704   +397

    No. It isn't a driver issue.

    Perhaps your new card is dead.. That seems a bit unlikely, but it does happen. It could also be your motherboard/agp slot.

    It has to be one of those 2 at this point I think since you've ruled out the cable/monitor idea.

    I assume you've reseated the card incase it didn't make a good connection the first time you put it in.
     
  9. Susuka

    Susuka TS Rookie Topic Starter

    Yeah, i've tried quite a few things.
    Well thanks alot for your help, i'll take it to the comp shop tomorrow and see what they can do.
    I would +rep you but im not sure it would make such a difference..Thank you again!

    Im not even sure if i can rep on this site.. :p
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...