Graphics driver not working right?

By Sketch Meister
Jun 30, 2007
  1. I have a GeForce 7950 GT 512 MB graphics card. I just downloaded and installed the 94.24 version of Forceware. Even after that, when i go to the Device Manager and look at the Graphics card, it says I still have version 6.14.10?!?! I don't know what the deal is. I've run 3D Mark06 and when compared to other computers with the same stuff, I get the lowest score. I looked at my system compared to the fastest system, and i have Forceware version 6.14.10 and the other system has Any ideas?
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    Did you remove the driver from the device manager, as well as as remove anything that appeared in add and remove programs before you then rebooted and installed the new version?
  3. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    Click on Start; select Add/Remove Programse; scroll down to NVIDIA drivers and remove.. Then restart your system. After that, then you can install the new drivers. You shouldn't have a problem after that. You shoud be using either the 158.22 or at least the 97.94 drivers for that card.
  4. Sketch Meister

    Sketch Meister TS Rookie Topic Starter

    The one that it gave me on Nvidia's site was the 94.24. Do they not even keep it up to date? Where did you find those? When it says to find the driver i need, i input: Graphics Driver < GeForce 7 Series < Windows XP/2000. I used that one.

    Edit: Actually...when i got to that page I went to the left of the screen and clicked "Products Supported". My graphics card wasn't listed, the "Geforce 7950 GT"
  5. raybay

    raybay TS Evangelist Posts: 7,241   +9

    They don't post "proprietary" drivers, or anything not created by the company... but will acknowledge it is good if you ask them.
  6. Sketch Meister

    Sketch Meister TS Rookie Topic Starter

    I looked up the 158.22 driver that sghiznaneck was talking about, but that is for geforce 7050 cards, and 8800s. Then again none of the drivers list my card, i'll have to email them.

    Edit: I tried installing the 158.22 driver on my 7950 GT, but it didnt work. It said "there wasnt any driver detected that was made for my card" or something like that. I have read other forums where they use this driver on this card. Idk what to do, because my initial problem hasnt really been solved.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...