TechSpot

Graphics/Gaming Problem

By Hughesy
Mar 28, 2005
  1. Not sure if this the correct forum but any help would be appreciated.

    Recently reinstalled Windows 98 Second Edition after I accedently deleted some key files. I've also reinstalled my graphics card with the cd I was given and everything is working correctly (so it says), but when I go to play games the graphics are all fuzzy with green colours.

    I've spent the best part of four hours trying everything from installing old directx versions, downloading from the graphic website (ATI), trying different colour and screen resolutions, reinstalling the games without luck.

    These are my computer specs. Just ask if you need any more.

    Operating System: Microsoft Windows 98 SE 4.10.2222A (Win98 SE)
    CPU Type: AMD Athlon XP, 2000 MHz (15 x 133) 2400+
    System Memory: 512 MB (PC2100 DDR SDRAM)

    Video Adapter: RADEON 9200 SERIES
    3D Accelerator: ATI Radeon 9200 SE (RV280)
    Monitor: Default Monitor (10438)
    Monitor: Orion OC-17DB06 [17" CRT] (10438)
     
  2. satchmo

    satchmo TS Rookie Posts: 83

    Catalyst

    It wasn't clear to me that you actually downloaded and installed the latest Catalyst driver for your Radeon card. The latest is version 5.3, and make sure (when you go under Device Manager) that you are in fact using the newest driver.

    the problem you're describing sounds like a typical driver glitch. What game are you playing, by the way?
     
  3. Hughesy

    Hughesy TS Rookie Topic Starter

    I'm downloading version 5.3 like you suggest, although it says it's for Windows 2000/XP so I'm not sure it's suitable for me.

    I'm trying to play the WW2 game Hearts of Iron 2, but I've tried some of my other games (new and old) and they are the same.
     
  4. Hughesy

    Hughesy TS Rookie Topic Starter

    Downloaded and went through the installation process and this came up

    "Setup was unable to complete the installation
    Try to setup your display adapter with a standard VGA driver before running setup"

    Any ideas?

    The help is very much appreciated.
     
  5. dgower2

    dgower2 TS Maniac Posts: 238

    2000/XP Driver for 98 System???

    Let's use some logic please. You need the driver for your OS. :monkey:
     
  6. Hughesy

    Hughesy TS Rookie Topic Starter

    Downloaded what I think is the correct driver for my 98 operating system, but unsurprisingly it had no effect. Still getting the same fuzzy graphics with green colours.

    Any more help from anyone?
     
  7. wiscountryboy

    wiscountryboy TS Rookie Posts: 60

    take the card out of your computer adn make sure the contacts are nice and clean, also take a can of compressed air and make sure the agp slot is dust free
     
  8. tbrunt3

    tbrunt3 TS Rookie Posts: 313

    What Motherboard do you have and you are not running onboard and a card are you??
     
  9. Hughesy

    Hughesy TS Rookie Topic Starter

    Motherboard Name Asus A7V8X-X
    Bus Type DEC Alpha EV6
    Bus Width 64-bit

    Didn't understand the last bit about a card, sorry.

    Thanks WiseCountry, will give that a try.
     
  10. tbrunt3

    tbrunt3 TS Rookie Posts: 313

    Sorry just thought you had on board vieo running too you only have the ATI card .. Did you update the motherboard chipset drivers ? Wich will update your Agp slot as well as everything else on your motherboard you will also need to the driver for your os for your video card .
     
  11. dgower2

    dgower2 TS Maniac Posts: 238

    Magnetism near by?

    Magnets cause severe discoloration on CRTs. Make sure you don't have any speakers near your screen. Also, clean the metal contacts of the video card with a pencil eraser and be sure to blow off any eraser debris.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...