Half-Life 2 problems

By FoxHound10
Dec 23, 2006
  1. All right here's the deal, my bro just bought me the holiday pack of half life 1-2 and it also has counter strike too. Now I loaded up Half-Life 2 and I made it past the video and even was able to play in game for a little. The problem is when I get to a loading screen it loads and then immediately afterward it lockups (stays on the same screen and the sound repeats) and then crashes to my desktop and says hl2.exe encountered an error. What do i do?
    I'm using a laptop:

    Dell Inspiron 9400
    over 1 gb of ram
    Intel Core 2 dual: Genuine Intel(R) CPU T2400 @ 1.83 ghz
    945GM Express Chipset Family

    At first I thought it might be my Video card but then how could i play the game up to a loading point it seems if that was the case it wouldn't work at all. Thanks -
  2. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    Steam has an FAQ section and your problem seems to be addressed here: Click here. Also, look toward the bottom of the page for similar, related problems that might also fit your situation.
  3. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    HL2 has a few quirks with audio compatibility. Make sure you have the latest audio drivers for your card or your integrated board.
  4. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 1,975   +9

    Do you have Norton Antivirus?
  5. FoxHound10

    FoxHound10 TS Rookie Topic Starter

    I already tried the stuff Steam said to fix it, I turned off my firewall completely by setting it to not even open up when I restart my computer and I only have the one firewall (which is norton). It still didn't work, I closed every program except the ones I need to run HL2 and still crashed. Where should I go to update my audio driver?

    This is the error message I get when It crashes... I don't know if it helps any.

    AppName: hl2.exe AppVer: ModName: datacache.dll
    ModVer: Offset: 00008a37
  6. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 1,975   +9

    Noton causes problems with Steam; although I doubt your current problem is due to this, it is suggested that you turn off Norton when playing a steam game.
  7. FoxHound10

    FoxHound10 TS Rookie Topic Starter

    I know I turned it off completely... so what should I do if that doesn't work and I tried what Steam suggested?
  8. BazzaJ

    BazzaJ TS Rookie

    I have the same problem - a brand new Dell but HL2-Episode1 crashes in exactly the same way you describe. My PC specs are as follows:
    * XPS/Dimension 410/9200
    * Intel Core 2 (2.66 GHz)
    * 1 Gb RAM
    * 256Mb ATI Radeon X1300

    Unfortunately, like you I don't have the answer. I've tried all fixes listed on the Steam website, but the same thing happens.

    Interestingly I can play their demo game HL-Lost Coast without any problems at all. Makes me think the problem may be at their end?

    Welcome your ideas!!
  9. cfitzarl

    cfitzarl TechSpot Chancellor Posts: 1,975   +9

    Steam has been having problem with certain motherboards (I forget which model), but they should have an article somewhere on their site.
  10. BazzaJ

    BazzaJ TS Rookie

    Hey, I just installed an update for Windows XP that is meant to solve known gaming issues with Intel Dual Core CPUs and things seem to be working fine for me now. The update is KB896256, available from the Microsoft website. Let me know how you go!
  11. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Do you have the latest video and motherboard drivers installed? Get the ones from Intel, not Dell. The ones from Intel are usually newer.
  12. thedarkrnite

    thedarkrnite TS Rookie

    locking up on small loading screens

    i get past the begginning video and play for a few minutes and then after i jump on the crate and open the door it locks up on me.....any tips on how to stop this other than defragmenting my computer?
  13. ninelivecat

    ninelivecat TS Rookie

    The good news is that there is an easy fix for the Save Load Error in Halflife 2 on the Intel 945GM integrated graphics card If you are launching Halflife 2 from Steam you need to right click on Halflife 2 then go into properties and enter the following into Set Launch Options
    +mat_forcehardwaresync 0 +snd_async_prefetch_priority 1

    If you are playing a Steamless cracked version of Halflife 2 (Better for Intel 945GM as Steam is an extra drain on it's limited graphical resources) you change the launch options by right clicking on the shortcut that you have created to Halflife 2 .executable
    It's inside properties on the shortcut so the full string will look like this.
    \\ hl2.exe" -steam -console " "+mat_forcehardwaresync 0 +snd_async_prefetch_priority 1

    Don't know if Lost Coast would be possible because it's more advanced than Halflife 2 Same with Episode 1 and Episode 2 They could be a bridge too far for this graphics card. It's a multimedia graphics card not really designed for high end gaming.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...