TechSpot

HDTV not showing in audio playback list

By Bugarri
Sep 24, 2016
Post New Reply
  1. I run upgraded windows 10 64-bit on HP Envy 17-j050ex with:
    i7-4702MQ @ 2.20GHz
    16 GB memory
    Intel HD Graphics 4600 and NVIDIA GeForce 750M

    I installed windows 7 and upgraded it to win10 pro, then I installed all the drivers.

    I couldn't get the hdmi to appear in the playback devices list.
    I tried checking the (show disabled devices) box.
    I tried reinstalling the IDT HD audio CODEC driver and the intel display driver but no results.

    One of the audio drivers (High definition audio device) behaves weirdly, the driver is not working even when I tried reinstalling it, it says device can't start code (10).

    The HDMI audio device used to appear before I recovered my system.

    Please help me I looked everywhere for a solution.
     
  2. jobeard

    jobeard TS Ambassador Posts: 9,315   +618

    I am sure you need to make the PC->HDtv connection at lease once for the device to show up. The first time connection does the install for the HDtv driver.
     
  3. Bugarri

    Bugarri TS Rookie Topic Starter

    It didn't that's the problem -_-
     
  4. jobeard

    jobeard TS Ambassador Posts: 9,315   +618

    Here's what I had to do.
    • Power off the PC
    • connect PC->TV
    • on the TV select the input corresponding to the connection you made. It will show No Signal
    now Boot the PC and it will autoconfigure the HDMI Driver
     
  5. Bugarri

    Bugarri TS Rookie Topic Starter

    The hdmi is connected and the display works fine the problem only with the audio
     
  6. jobeard

    jobeard TS Ambassador Posts: 9,315   +618

    So, right-click on the sound control in the system tray
    click on Playback devices, then Playback
    set Speakers/headphones as default
     
  7. Bugarri

    Bugarri TS Rookie Topic Starter

    I appreciate your help man but all you gave me is basic troubleshooting steps that will not help honestly
     
  8. jobeard

    jobeard TS Ambassador Posts: 9,315   +618

    Sorry there man; I just reported steps I took to get mine working. best wishes
     
  9. jobeard

    jobeard TS Ambassador Posts: 9,315   +618

    BTW: there's never a specific device shown as HDTV - - just a third speaker option and only when connected - - set it as default just once.
     
  10. Wendy Oltman

    Wendy Oltman TS Booster Posts: 128   +16

    If you navigate to the playback devices list, right click on any empty space and a menu should appear with two options called "show disabled devices" and "Show Disconnected devices", make sure these care both checked. Let me know of any updates.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...