TechSpot

Help - can't access XpPro PC over network

By technoheckno
Nov 15, 2004
  1. Hi,
    excuse me asking about something which I'm certain that more thorough searching might explain. I have networked 3 computers through a Belkin Adsl modem/ wireless router. One PC, wired connection, runs XP pro and can see and access both other PCs, one runs W98(wired connection) and can see the XP pro PC but can't access it(not a major problem), the other PC is a laptop with XP Home which connects wirelessly and can also see the XP pro PC but can't connect. All are in the same workgroup and have unique names. The message I get when trying to access the XP Pro machine is:
    “'machine-name’ is not accessible . You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

    Logon failure: user account restriction. Possible reasons are blank passwords not allowed, logon hour restrictions, or a policy restriction has been enforced.”

    All three machines can access the internet through the router. As far as I know I have not enforced any policy restrictions or required any passwords. I have tried turning off all anti-virus and firewall programs but that makes no difference.
     
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    On the wired XP machine, open up a new user-account for the laptop and the W98.
    Give them the proper rights (if they are all your PCs, you could give them admin rights.
    To access from the W98, use the username and password from the new account to access that wired XP. Make sure file-sharing is enabled.
     
  3. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Also you might find mapping a drive on each of XP Home &98 to a share on the main machine will force them to log on automatically.
    Home and 98 cannot join a Domain ,means you have to logon manually or ....
     
  4. n3tw0rk t3ch

    n3tw0rk t3ch TS Rookie Posts: 17

    also, try setting the user names on all three machines to be the same user. if they are all yours, this should not present a problem
     
  5. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    Thanks

    On reflection I maybe didn't provide quite enough ibformation - realblackstuff, I'd already read your suggestion in one of your earlier posts and set up user accounts :slurp: , Liquidlen - I tried setting a share on the XP Pro machine but I get the self same message above if I try to map to it, n3tw0rk t3ch I'll give a try at setting up user accounts with the same name on each machine. My suspicion is that the root of the problem may be some arcane setting in the local security policy/security options settings which I haven't sufficient knous to sus out - and I am the living example of a little knowledge being a dangerous thing!
     
  6. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    ooops - neglected to also mention that on the XP Pro machine under security options/Network Options - sharing and security model for local accounts is set to 'Classic - local users authenticate as themselves' - if that means anything to anyone, I think I read somewhere that was a way to go when networking XP machines.
     
  7. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Real... Quote

    "On the wired XP machine, open up a new user-account for the laptop and the W98"

    This what he was referring to ,since you cannot join a domain there has to be 1 user common to all 3 machines and that user logs on to shares.
    when you have done this windows will ask you for a name and password to do this.
    you can make a batchfile that will do this also,but it just works faster with a mapped drive.
     
  8. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    Doh

    Sorry - I guess I must be thick - I'd set up user accounts for the computer names :haha: - But I've tried setting up an account with the same name on each PC, with Administrator rights on the XP Pro and the XP Home one, but only the XP Pro PC can see or access shares on the other 2 PCs. Both other PCs can see the XP Pro one and each other but when I try and map a drive they ask for a password then say the password is wrong :confused:
     
  9. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    O.K. Techno; we are using terms rather loosely and networking settings are very specific, and If it still is not working we have missed something,

    The 1 common user account has the same 'name'
    and same 'password ' set on all 3 machines

    All 3 machines have the same 'Workgroup name'

    Each 'machine' has it's own unique name.

    You have File and Printer sharing set on all machines(Property sheet of each connection)

    You have run Networking wizard on Pro machine first and also on Home (be watchful, the Wizard will change Workgroup name to Default each time it is run)

    On the Pro machine you have a Folder or Drive set to allow it to be Shared ,with a sharename,with the "common user" allowed full rights

    Try to Map a drive from the Home and 98 machine to the Pro "share" ( be very patient ,windows can take 15 min or more to logon It must work out which machine determines certain TCP/Ip settings)
    I have actually try to force the logon by re-sending the password sceen 5-6 times.

    Also I have found using Static IP addresses for each machine quicker.

    Don't give up we'll be around
     
  10. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    Thanks for that Liquidlen,
    I'm making progress - some forward, some sideways and some backwards :haha:
    There is a common user with same name and pw on each machine
    All 3 machines have the same workgroup name
    Each machine has a unique name
    File and printer sharing is set on each machine
    The network wizard has been run on each machine(Pro first)
    The Pro machine has a shared folder with the username in the share group

    Latest is (you can laugh cos I am)
    The laptop can now access the Pro machine and vice-versa
    THe W98 machine can access the XP Pro machine from network neighbourhood - and can see the laptop but gets a message saying the machine is not accessible :)
    The XP Pro machine now can't connect to the W98 machine - the folders appear in network neighbourhood but when I attempt to open them a password box appears which has the username W98/guest greyed out - there isn't a guest account on the W98 machine :confused:
    The laptop can't see the W98 machine at all - but I'll keep trying.
    I never realised that Windows could provide so much harmless amusement.
    Thanks very much for the assistance
     
  11. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Hey you have made excellent progress you are dealing Microsoft products,Pat yourself on the back and let see what we need to do to clean up some of the glitches.I laughed alot when I mixed OS es on my Lan, but I just chuclkle since I no longer use 98 in the mix.
    It has been a while for me with 98 so I need to do some checking or may be someone else has more experience will jump in.
    Did you use Static IP addresses?
    Do you use any firewalls,and if so which ones?
    Are all windows OS updated?
    I do seem to recall using IPX or Netbios to get around 98 and XP Home limitations. Later for that.
    I gotta go ...
     
     
  12. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    I guess there's a TV show just waiting for someone to make it 'Laugh along with Bill Gates'.
    Didn't use static IP addresses - yet - IP seems to be resolving OK (the laptop can now see W98 pc in network neighbourhood/windows network/netname, but gets the same message as the laptop was getting when I try to map a drive :rolleyes: )
    Windows firewall disabled on XP machines - ZoneAlarm on all machines, makes no difference if it's off or on(I've tried) IP range is set in trusted zone. AVG on laptop - I've tried with it disabled, Kaspersky AV on XP Pro, PCCillin on W98 - I've tried turning them all off to no avail.
    Netbios is enabled over TCP/IP on all machines.
     
  13. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Bill would screw up the show ,he would want all the audience to 'register ' so that he could be sure he wasn't getting ripped by 'Bootleg ' audience members.

    Anyway ,You suit yourself I know it works,but there is a lot of traffic back and forth with auto settings of TCP. Home ,& 98 especially drag their feet.
    In Zone alarm it is good to enter each server by name with it's IP range Or Static as a trusted 'Host 'and leave it running unless you want to test something.
    Anti virus should not affect any of this.
    I'll be back!
     
  14. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    O.K. Leaving a couple of notes to try if you like.
    You should be aware that the issues you are having now are security based .XP network wizard does not like each Computer having direct access to the Internet.I was able to get all my machines to interact but the configuration is a pain.And you always have to manually logon from Home & 98.There is one other way IPX/SPX, it too is a pain to set up (and can slow down your network a bit) I don't know if it is worth ,unless you don't see your self upgrading all machines to Pro ( Pro has none of these issues)one day .Any have fun I will leave you with the following;

    -For Laptop & 98 to interact you must create a Share on each .
    -98 needs Client for Microsoft Networks' properties set; try' Logon and restore network connection
    -98,Confirm Access control or User and fill in pasword and users rights
    -ICS should be off on Home Machine
    -Simple File sharing uses 'everybody/guest' as security protocol ,I don't recommend it.
    -Home & 98 must both logon to Shares at each start, There is a batch file that will do this from a short cut on 98 Desktop.
    Keep Laughing!
     
  15. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    oops

    Sorry - being thick, but I seem to have got a little bit lost..I think I have a share (shared folder ending $) set up on both laptop and 98.
    98 has Client properties set as you describe but where you say confirm access control or user and confirm user's pasword and rights I'm not sure - I have a user set up with a password but I don't see where I give user rights on 98 :)
    By Simple file sharing do you mean the sharing set up on 98?
    ICS is off on the Home machine
    Home and 98 must both logon to shares at the start - you mean that when they access a shared folder on another machine they use a password? Apologies it's as I said a little knowledge on my part is a dangerous thing :giddy:
     
  16. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    Well a little bit further sussed out - Now I can connect from XP Pro to W98 and vice-versa - the folders on the W98 PC were password protected and it was that password rather than a network password which was required :blush:
    However I still can't get the laptop(XP Home) to access the W98 PC or vice versa but definite progress.
     
  17. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    No apology necessary,we all learn this way!
    From bottom to top of your Questions;
    Yes, 98 & Home must enter a password to access the Shares they are after,for EACH session.(You should be getting a request window when you dbbl click on a share in Explorer)

    Only Pro and Home can use' Simple File Sharing'
    98 has it in principal ,but I did not use it, it causes other things not to function.If it is turned off leave it off.

    User security is set in 98 by the'AccessControl' tab in Control Panel>right clk 'Network Nieghbourhood>Properties
    set user level access control>Add user page>highlight user and > Full Access (should be self explanitory from there.

    There, have some fun with that.
     
  18. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    Hi,
    Thanks for that. Unfortunately my User Access Control in W98 only offers the possibility of setting user access and inputing a location from which to obtain a list of users .... :giddy: I turned off sharing - and couldn't access the folders on W98 from the XP machine so I turned it on again :D That was after I :eek: had done Ipconfig /release_all and then Ipconfig /renew_all on the W98 machine which lost it from the network completely - but I'm back to the stage I was b4 once again :haha:
     
  19. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    "Simple File Sharing " is a setting in Home and XP when you switch it on it use a security setting for "Everbody" level sharing.This defeats the security of individual 'Users'
    Running IP config Renew was not necessary from where you were in Post # 16
    Because now I don't know where to assist you.
    Can you get back to how your network was working in #16
    I am not sure what you did when you say you turned off 'Sharing in 98" it will help if you are very specific with the terms you use.
    Is your copy of 98 Second Edition?
    I am surprised you don't have the same pages my copy does.
    Anyway if you are not beaten then let me know what is working ,whats not working ,I will hang in if you do.
    I also suggest you concentrate on getting XP pro & Home machines to work first they are easier and you can run the network Wizard .Then the Pro machine can make a floppy disk of the network wizard settings to run on a 98 machine.
     
  20. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    Hi,
    Sorry to confuse I meant that I'm back where I was in #16. i.e. laptop(Home) works with XP Pro and vice versa, 98 works with XP Pro and vice versa, but laptop and 98 machines appear in each others network 'pictures' but won't talk to one another.
    98 is 1st edition.
    What I meant about sharing was that in 98 I have the options of share-level access control or user-level access control which has a field in which to enter a name to 'Obtain list of users and groups from'.
    :)
     
  21. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Wheeewww, I thought .... nver mind.
    Well you are in good shape then.
    In the 98 only
    Go to Control panel>open Networks icon
    On the page 'Access control, click on'User level access button and type in the "computer's name "of the XP pro machine, (You might have to put the Home machine here to after a comma,but try without first) >press ok
    If you have shared correctly> My Computer open up C:\ drive(wherever the shared folder or drive is)and >right click the' Shared' folder>Properties
    and on the Sharing tab you should be able to add you user names and control levels,, Press ADD
    Try this and get back to me.
     
  22. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    Thanks for that - but unfortunately what I get when I input the XP-PRO computer name is 'windows could not find the specified security provider on the network. Do you want to use the name you typed anyway?' ...If I select yes I get a box with a drop down list 'Select the kind of authentication you typed: Windows NT Server or Windows NT Domain' - I'm pretty certain that neither of those are quite what's required :D Maybe this isn't possible 98 First edition.
     
  23. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Select Windows NT domain and enter the Pro machine name.(You may have to add the Home name also after a comma,but I would try it alone first)
    This is simply to make 98 give you a logon name window when you attempt to get to a share.
    Also confirm on Pro and Home that the allowed security level for the users is set to Full Control
    (This is at Right Clicking on the actual share and going toProperties> Security& in Advanced enter the user )
    You must UNcheck the 'Allow inheritable permmission ..........' tag at the bottom of the Properties page Security tab for all of your Shares
    on each machine.
     
  24. technoheckno

    technoheckno TS Rookie Topic Starter Posts: 24

    :grinthumb Well how did that happen? I tried as you suggested with W98 - but it wouldn't obtain a list of users when I pressed the add button, nor would it allow me to input 2 computer names separated by comma, semi-colon or anything else imaginable. But when I'd attempted to do that I tried looking in network neighbourhood and to my surprise I could access the shared folders on the laptop :D The downside was that neither of the other computers could access W98 - so I re-enabled share-level access on w98 - and guess what everything can see each other and access each other's drives! Thanks very much for the help - whether it was enabling user-level access that was the trigger - who knows :) But I reckon that you can congratulate yourself. Cheers - If you ever get to Northumberland UK I owe you a pint.
     
  25. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Glad to be of service;
    Enjoy your network ,you'll have to make that Pint, a scotch though ,if it is all the same to you.

    When the dust clears and you feeling like messing around,I will leave with a couple of items to think about.
    Get an update to Second Edition it is better with a lot of stuff ,including networking.( And it is Free)
    Do some reading about Static Ip addresses for your Lan only.
    Finally there is a constant process on Windows workgroup networks called 'Browsing'.I won't go into it now but there is a way to affect 98 to keep it on the lan more consistently& and Quicker.
    You can save this for when you want to laugh some more.
    We'll see you around!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.