TechSpot

HELP! External HD not showing up in My Computer!

By quirkinator
Sep 9, 2006
Topic Status:
Not open for further replies.
  1. I recently installed a Belkin FireWire 3-Port PCI Card successfully. A friend gave me his external 40gb HD by Lacie to put music on. When I hooked the two up and restarted the computer, nothing happened. I don't see it in the device manager either. I am running on a POS ME and it functions for basic needs like internet, music, and the calculator. I know, sad, but it is what I've got. Anyways, if any of you can help, that'd be great. I'm not super tech-savvy, but I learn really quick, and am always greatful for suggestions. Thanks!
  2. Hofstadter

    Hofstadter TS Rookie

    Sounds like you havnt installed the drivers, or there nor working properlly, Im not to sure about these things either, so ill wait for a techie to come and confirm this, if im right :p
  3. quirkinator

    quirkinator TS Rookie Topic Starter

    The install was right, but...

    The driver was installed correctly, and does show up my device manager as well as on the quick launch thingy. Just not the external HD. : ( But thanks, I did go and check to make sure. : )
  4. Hofstadter

    Hofstadter TS Rookie

    You said you didnt see it in device manager, now you can, yes?
  5. quirkinator

    quirkinator TS Rookie Topic Starter

    What is and isn't working

    The FireWire is connected fine and shows in the device manager. The HD doesn't register at all, but the light is on, so I'm assuming there isn't a power problem from PC-FireWire-HD.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.