TechSpot

HELP, mouse and keyboard work fine in bios but stop working at the welcome screen!!

By bobbyyy
Jun 3, 2007
Topic Status:
Not open for further replies.
  1. i have tried everything, taking out everything except the graphics card, 1 stick of ram and the cpu but i cant get the mouse and keyboard to work on the welcome screen. my computer has the following specs:

    250 GB hard drive
    ATI Radeon 9500 series graphic card
    1024 MB Ram
    packard bell

    please can anyone give me some advice on how to fix this as i dopnt want to take it to a professional and pay for it to be fixed!!!
     
  2. CCT

    CCT TS Evangelist Posts: 3,556

    What does your manual for your as yet unidentified motherboard say about enabling USB ports in the Bios?
     
  3. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 25,948   +19

    Thread moved.
     
  4. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251

    Hi Bobbyyy and welcome to the TS Forum :wave:

    It sounds like the keyboard and mouse drivers are corrupted, I have seen this happen before, its a rare fault though and maybe symptomatic of other issues such as a failing OS or HD.

    You can try a repair by booting from the Windows CD and choosing the autorepair function, this should replace any missing files.

    Failing that it maybe a case of doing an over the top install from the CD, but try the above first and come back to us.

    Also whilst your here can you read the following guides, we ask this of all newcomers.

    Techspot FAQ.

    A message for all newcomers.

    SNGX1275`s A guide to making a good post/thread.


    Regards
     
  5. jesterc25

    jesterc25 TS Rookie

    KB & Mouse stop working at windows login screen

    Hey there. New guy here. I'm having the Same issue as I've seen posted. KB and Mouse work fine in BIOS (well not the mouse, but you knw what I mean). but as soon as I get to the Windows Welcome screen. they don't work (Light are still on {num. lock. mouse light etc.} they WORK, it's as iff Windows won't accept the input??? I HAD a USB Bluetooth Logitech MX5000 Laser set (KB & Mouse) they work Fine on my X0box 360, plug and play. I tried USB kb N mouse, I tried PS2 ones, NONE of them work. I even went as far as putting in a NEW HD, Wipe, fprmat, and re-load Windows. it all was fine till I got AGAIN, to the windowws welcome screen "Windows will now set up your desktop for you" "Click OK to continue" KB and mouse are dead, can't click anything. HELP!!!!!!!
    got $3500 invested in this rig, and I'm about to throw it out the window. MY next step would be a NEW MoBo. as I've done Everything else.

    Thought. I have NOT reset BIOS to defaults. but it's a NEW windows install, I shouldnt' have to do that should I??

    Specs. P5B-E asus MoBo, EVGA 7950GTKO PCI-E grafix. WAS a 80Gig Sata, NOW running 4gig, IDE. 2Gigs of Ram, and intell core two Duo 1.8Ghtz
    P.S. I did NOTHING to it, Fri. worked fine, boot up SAT, DEAD. NO changes Short of I un-pluged my USB Portable HD from the PC, but I do that all the time to take it out of the house.
     
  6. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 2,251

    Hi

    Your posting in a thread that's over a year old...

    But yes it sounds like a mobo fault.

    regards
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.