TechSpot

HELP - Windows XP "Out of Memory" Message with 1 GIG RAM

By DLambie
Feb 21, 2005
Topic Status:
Not open for further replies.
  1. I am having a bit of problem running Band Manager & DET programs - both programs created using FoxPro -I have 1 gig of RAM but still get this "Out of Memory" message when trying to open either one.

    It tells me to create an boot.ini file which can not find.
    This is what the program web site says to do and unsure how to go about doing this and any help would be great.

    "Windows 2000 or Windows XP "Out of Memory" Message

    Some computers that have Windows 2000 or Windows XP installed and have over 512 MB of memory are getting the "Out of Memory" message when trying to run Band Manager. This is caused by an incompatibility between the language used to write Band Manager and Windows 2000. The work around that you can limit the amount of memory used by the operating system. You can create a boot (in the Boot.ini file) that uses a special configuration for Visual FoxPro. To limit the amount of memory that Windows 2000 uses, use the MaxMem switch. Using a trial and error method, determine the maximum amount of memory you can use before you receive the "Insufficient Memory" error when launching Visual FoxPro. For more information about multi-boot and the MaxMem switch, please see the Windows NT documentation."

    Thanks,
    David Lambie
    Mackenzie, BC
     
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    There is a boot.ini file in your C:\

    If you open it (with a text editor like Notepad) you see a line under [operating systems] that looks like this:
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

    Copy that line and paste it under itself (note that if you mess up the boot.ini file you will not be able to boot Windows anymore). Change the text in quotes to read "XP for FoxPro" for example.

    Add a /maxmem=xxx option to the end of the line after /fastdetect and all others. xxx stands for the amount of memory you want to have. As said, you will have to experiment. 512 should be a good value to start with.

    When you reboot your computer then you should see a boot menu with two options: XP Professional with maximum memory and the new one you created for FoxPro with limited memory.
     
  3. DLambie

    DLambie TS Enthusiast Topic Starter Posts: 99

    My boot.ini is as below:

    [boot loader]
    timeout=3
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional Edition" /noexecute=optin /fastdetect
    C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdcons


    I should have the boot.ini look like the following - as want to be sure:
    (the maxmem=512 is this the only place I place it?)

    [boot loader]
    timeout=3
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional Edition" /noexecute=optin /fastdetect
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="XP for FoxPro" /noexecute=optin /fastdetect/ maxmem=512
    C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdcons
     
  4. Nodsu

    Nodsu TS Rookie Posts: 9,431

    Yes, this is OK.

    Did you type this in instead of copy-paste?
    I am quite sure it should be "WINDOWS", not "WINDOW S" there.
    And it should be "/fastdetect /maxmem=512" not "/fastdetect/ maxmem=512".

    Otherwise it is exactly as needed.

    You might want to increase the timeout value too. At the moment you have only three seconds to make the choice.
     
  5. DLambie

    DLambie TS Enthusiast Topic Starter Posts: 99

    boot.ini

    thanks a million
     
  6. Eorling

    Eorling TS Rookie

    I have the same problem, and I have done what Nodsu recommended. But strangely enought, my computer still boots in the ordinary way. Do you know why that is. My file is named boot.ini.backup instead of just boot.ini, is that a problem. The timeout was set to 30, and I havent changed that.

    What can I do?
     
  7. Nodsu

    Nodsu TS Rookie Posts: 9,431

    You probably didn't edit the real file or your editor didn't save it properly.

    The file is marked hidden, system and read-only and many text editors have a problem with that.

    Try another editor or clearing the system and read-only bits from the file.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.