TechSpot

Help with ICS

By skyhigh
Mar 5, 2002
Topic Status:
Not open for further replies.
  1. First, a thanks to all those have helped solved my problem.

    I have managed to get both of my comps working fine now.

    I have networked them together, able to share files and everything but the client comp can't surf the net. I connect using a cable modem and have 2 NICs in the server comp.

    I have enabled ICS on my Internet NIC tab and have set an IP of 192.168.0.7 on my secondary NIC which I use for networking the 2 comps together.

    As for the client comp, I have enable TCP/IP and set it to obtain IP and DNS automatically.

    The server comp can surf the net without any problems but the client comp cant.

    Can somebody help me with this ?

    Thank you.
     
  2. eof

    eof TS Rookie

    hmm....change your local network card from 192.168.0.7 to 192.168.0.1

    and if that doesn't fix it then change your other computer to not get ip/dns automaticly and just hardcode in 192.168.0.1 as your gateway and 192.168.0.2 as your ip and 192.168.0.1 as you DNS server...that will definitly work....
     
  3. Rick

    Rick TechSpot Staff Posts: 6,304   +52 Staff Member

    Agreed. The server should be set to 192.168.0.1. It won't work otherwise.
     
  4. skyhigh

    skyhigh TS Rookie Topic Starter

    I have switched the IP of 192.168.0.7 to 192.168.0.1 and hardcoded the client NIC with following details.

    IP : 192.168.0.2
    Subnet : 255.255.255.0
    Gateway : 192.168.0.1

    Preferred DNS Server : 192.168.0.1

    The ICS still does not work.
     
  5. Arris

    Arris TS Evangelist Posts: 4,551   +97

    I suggest doing a search on the Old 3ds forums as this was a topic detailed many times by members.
     
  6. eof

    eof TS Rookie

    Yea...something is up because with those settings there is no way this shouldn't work...I would question that you actually have sharing checked...=)
     
  7. Phantasm66

    Phantasm66 TS Rookie Posts: 6,504   +6

    Can you try to just use DHCP for the adapter that is serving the connection to the other machines which you previously set as 192.168.0.1. Of course, let the other (internet connected) one alone, but use DHCP for the sharing connection.

    I believe that there is a small DHCP allocator and WINS proxy, DNS proxy and so forth built in to all version of Windows past 98. DHCP should be fine for your internet network, but you will probably find that its 192.168.0.1 anyway once its been DHCP allocated.

    Use DHCP on the client computers as well. Remember to enable ICS in the internet that HAS the internet connection, not in the one you are sharing it with (i.e. 192.168.0.1 goes to DHCP and ICS is enabled in the other card which is directly internet connected.)
     
  8. Mac_Bug

    Mac_Bug TS Rookie Posts: 62

  9. Arris

    Arris TS Evangelist Posts: 4,551   +97

Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.