TechSpot

Help with sharing files through linksys wireless router/wired..

By Morketh
Feb 5, 2006
Topic Status:
Not open for further replies.
  1. Okay, I have a Linksys WRT54G wireless router and I have one computer hooked up through ethernet and one laptop hooked up wirelessly..

    OS: Win XP SP2 on both

    I used winxp home networking on computer and joined "workgroup" on the computer

    I found the wireless connection on laptop and connected and joined "workgroup" on laptop

    I did not set any static IPs I just left that alone..

    The problem Im having is I share out my whole C: drive on both laptop and computer and I also shared out individual folders and files and made them all changeable by all users..
    When I go to my network places and browse to the workgroup "workgroup" then browse to the computer from the laptop, it gives me access denied when i try to open any of the shared folders... when I use my computer to go to my own shared folders... i still get access denied oddly enough..
    I do not know why..

    The laptop can access its own shared folders when it goes through my network places but computer cannot ..

    niether the computer nor the laptop can access the others files because they get access denied...

    ive done this before and had no problems the only thing i can think of is that i have downloaded some windows update that added more security but i just have no clue what

    anyone know?
  2. Spike

    Spike TS Rookie Posts: 2,371

    Not sure - had this problem a long long time back and can't remember how to fix it.

    First there's the most obvious... a reboot of both machines can sometimes help.

    Then there's the firewalls - check that both XPSP2's firewall and any installed fiewall is disabled for diagnostic purposes, and to turn off WEP encryption.

    Third is to have both computers "authenticate as guest when computer information is not available" on the connection properties.

    Fourth, ensure that you have the TCP/IP, Client for Microsoft Networks, and file and printer sharing for Microsof networks are installed on both machines (all three of them installed on each).

    Failing this, with WEP encryption and your firewalls disabled, set static IP's to each computer (depending on which range the router is using, this might be 10.0.0.1, 0r could be 192.168.0.1, or 192.168.1.1 or whatever. Hitting tab at the end of entering the ip will automatically insert the correct sun=bnet address into the next field). so....

    on the desktop pc,
    set (for example) IP to 10.0.0.3
    set Subnet to 255.0.0.0
    set Gateway to 10.0.0.2 (or whatever your routers IP is)
    set DNS to 10.0.0.2 (or whatever your routers IP is)

    on the laptop,
    set (for example) IP to 10.0.0.4
    set Subnet to 255.0.0.0
    Set Gateway to 10.0.0.2 (or whatever your routers IP is)
    set DNS to 10.0.0.2 (or whatever your routers IP is)

    After this, run the network setup wizard on both machines again, reboot both again, once restarted, make sure your installed firewall and WINXP's firewall is disabled on both machines, and see if it's fixed.
  3. Morketh

    Morketh TS Rookie Topic Starter

    Alright, still the same thing..

    I think my computer is the problem.. it cant even access the workgroup.. when I go to my network places and click view workgroup computer or even when i just try to view the workgroup it gets access denied..



    When I go to my network places on my laptop.. it can see and access its own shared files just fine

    Is there any way I can set all network security settings to low or something.. jeez I dont get it :(
  4. rdlaub

    rdlaub TS Rookie

    I am having the same problem although not with a laptop. I have a post on this forum as well. Mine had been working and then mysteriously stopped. I cannot figure it out.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.