HELPP!! Screen Goes Black, But Laptop Still Running

By acidrain123
Aug 16, 2007
  1. Hey, My notebook is an Advent 7211 on Vista Home Premium. it was working perfectly lastnight. i plugged my digi camera in and left it to charge overnight, i closed the laptop.
    i opening it up this morning, and the screen was just black, its on, but just black. the HDD fan is constantly on. i turned it off, and tried turning it on again, it loads up with the advent welcome screen and then goes into windows error recovery giving me the two options,

    launch startup repair (recommended)
    start windows normally

    i've used both options, but still the same happens, it loads for a second then thats in, black screen with HDDfan spinning away.

    i've also gone into repair mode. same thing happens.
    i've tried starting it up in safe mode, it loads all the drivers, then stops.

    unfortunatly, i didn't get any DVD discs intime to copy the "Tech Guys DVD" onto disk, so i can't even format it.

    i don't know what to do anymore. do i download Vista and start all over again.. or does anyone have any ideas?

    ps. before i closed my laptop, my camera was being weird and not charging properly, i had to put the cable into my camera halfway till it beeped, then put it in. and an error message showed up on the screen saying that it isnt functioning properly. i don't really see this destroying my computer, but still..

  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Press F8 before the laptop shows the Windows screen... Instead of selecting "Start Normally" select VGA Mode and restart the laptop
  3. acidrain123

    acidrain123 TS Rookie Topic Starter

    i don't even get a chance to do that now! it turns on, but now the screen just acts as if its off.
  4. captainsimon

    captainsimon TS Rookie

    I had a HP laptop that did this.
    It was a loose connection on the screen hinges, try moving the screen up and down to see if it starts displaying again.
  5. acidrain123

    acidrain123 TS Rookie Topic Starter

    i've just tried plugging my old monitor into it, but nothings getting sent through.. :( going to take it to a shop sometime soon :(
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...