TechSpot

Home ethernet network problem with file sharing

By adahn
Jul 4, 2005
Topic Status:
Not open for further replies.
  1. Here is my setup: I have two computers - one running WinXP Home, the other running WinXP Prof - that I have hooked up in a home network. The computers are hooked to a LinkSys switch with regular ethernet patch cables. The WinXP Prof has a NVIDIA nForce MCP network card, the WinXP Home computer has a Intel Pro/100 VE network card. The WinXP Prof computer is also hooked up to the Internet through a modem. Since I want to share the Internet connection, in the Network Setup Wizard, I designate the WinXP Prof computer as the computer providing the connection that the computer with WinXP Home will also use. This works fine and I can use the internet from both computers. I can also play LAN games on the two computers fine.

    However, when trying to access either one of the computers (from the other) from My Network Places and share files and other resources my network does not work. From the WinXP Prof comp I can open the workgroup and see the computers in it, but can't access the WinXP Home computer. The WinXP Home computer sees the workgroup but can not open it. I would welcome any ideas as to the nature of my problem.

    Thanks,
    Adahn
     
  2. Spike

    Spike TS Rookie Posts: 2,371

    When I get issues like that, the most common cause turns out to be the firewall(s) on either machine.

    as a quick test, disconnect from the web, and disable both the windows firewall, and any software firewall you may have ON BOTH MACHINES, and try again.

    If you are then able to accss each computer from the other then you've found the problem. If this doesn't work, it's something else. (do you have client for MS networks installed and file and printer sharing?)
     
  3. adahn

    adahn TS Rookie Topic Starter

    Spike: I have only the WinXP firewall installed (on both computers) and have tried disabling it, but the problem is still there. I've also tried switching the main computer through which the internet is being used, again to no effect.

    Some other symptoms: Sometimes the two computers get IPs of the form 169.254.?.? and I get a "Limited or no connectivity" message. This happens when I try to run a different network set up - for example, local network without internet access.
     
  4. adahn

    adahn TS Rookie Topic Starter

    I just solver my problem :) Installing the IPX/SPX/NetBIOS protocol suite fixed everything. If anyone is interested in a longer discussion of the (similar) problem, here is the info:

    >Like most of you, I have experienced (!) very slow local networking using
    > "TCPIP only" once I introduced an XP box on my LAN (the traffic was
    > excruciatingly slow from the XP box but not from the my Win98 boxes). For
    > whatever reason, it seems that the TCPIP implementation in XP is routing
    > local traffic through the Internet, which slows down LAN traffic to a crawl.
    >
    > I have 3 boxes: 1 XP Pro and 2 Win98. I use a network Hub (Intel Office
    > Connect) and a Hardware Firewall (SonicWall SOHO/10) with cable modem access
    > (Motorola CyberSurfer). My cable modem hooks to the firewall which itself is
    > hooked to the Hub.Of course, each box is also hooked to the Hub. The
    > hardware firewall serves as a router and a DHCP server. Each box accesses
    > the Net directly. I do not use ICS (Internet Connection Sharing) or XP's
    > software firewall. My LAN is setup as peer to peer as opposed to
    > client/server. Peer to Peer seems to be the default setup.
    >
    > As a result of the difficulties encountered with "TCPIP only" for LAN
    > traffic, I decided to use "NWLink IPX/SPX/Netbios compatible transport
    > protocol" for LAN traffic. There are general rules to follow for any LAN
    > setup. First, configure each box to use the same workgroup, such as "Home"
    > or "House" or whatever else you want as long as it's the same for each box.
    > Each box must also be configured with the same network protocols. Shares
    > must be enabled for the files and printers you wish to share on each box.
    > Software firewalls such as ZoneAlarm should be disabled until the LAN is
    > configured and working. Once the LAN is configured and working, software
    > firewalls can be re-activated but configured to allow local traffic
    > otherwise local traffic will be blocked.
    >
    > To disable XP's software firewall, click on "Start" then "My Network
    > places", then "View Network connections" on the top left pane, then click on
    > your "Local Area Connection" to hi-light it, click "Change Settings of this
    > connection" on the top left pane, click on the "Advanced" tab on top and
    > uncheck the box next to "Protect my computer and network...". There you go,
    > XP's software firewall is disabled!
    >
    > While you're still in the "Local Area Connection Properties" dialog box (on
    > the XP machine), take a look at the window under "This connection uses the
    > following items:", you'll see a list of protocols that are installed. If
    > "NWLink IPX/SPX/Netbios compatible transport protocol" does not appear in
    > this window, click on the "Install" button, then "Protocol", then
    > "Microsoft" than "IPX/SPX/NetBios Compatible Transport Protocol" and take it
    > from there!
    >
    > You must also install this protocol on each Win98 machines by clicking
    > "Settings", then "Control Panel", then "Network", then the "Add" button,
    > then "Protocol", then "Microsoft", then the "IPX/SPX Compatible Protocol".
    > To get IPX/SPX to work on a network that includes an XP machine, you must
    > activate NetBios and bind the NetBios protocol to "File and Printer sharing
    > for Microsoft Network" as well as "Client for Microsoft Network" on each box
    > on the network. I have uninstalled QOS on my XP machine as it serves no
    > purpose. It seems that XP installs NetBios for IPX/SPX automatically once
    > IPX/SPX is installed. IT'S NOT THE SAME WITH WIN98. In Win98, after
    > installing the IPX/SPX protocol and re-booting, you have to click "Start",
    > then "Settings", then "Control Panel", then "Network" and then, hi-light the
    > "IPX/SPX protocol", click "Properties", click on the "NetBios" Tab on top
    > and check the box "I want to enable NetBios over IPX/SPX". You must do this
    > for each Win98 machines on your LAN. I don't know about WinMe, but I suspect
    > that it is pretty much the same as in Win98.
    >
    > To look at bindings in XP, click on "Start", then "My network places", then
    > "View Network Connections", then click on your "local area connection" to
    > hi-light it. Once there, click on "Advanced" on the top menu bar and then on
    > "Advanced Settings". You'll then see a tab on top called "Adapters and
    > bindings". There you are! You'll see "File and Printer Sharing for Microsoft
    > Networks" with the protocols that are bound to it. Ensure IPX/SPX is there
    > and checked. Also, ensure TCPIP is unchecked as you do not want TCPIP for
    > your LAN once you decide to use IPX/SPX. You will also see "Client for
    > Microsoft Networks". It's the same thing there also: check IPX/SPX and
    > uncheck TCPIP.
    >
    > Now close this dialog box. Hi-light your "local area connection" again and
    > click "Change settings of this connection" on the top left hand pane. Click
    > on "Internet Protocol (TCP/IP)", click on "Properties", click on the
    > "Advanced" button on the General Tab page, click on the "WINS" tab on top,
    > check the box that says "Disable NetBios over TCPIP". Remember, you do not
    > need NetBios over TCPIP for your LAN if you use IPX/SPX. While you're there
    > ("Advanced TCPIP Settings"), you might want to add a default gateway if your
    > LAN is anything like mine by clicking on the "Ip Settings" tab on top, then
    > the "Add" button and add your default gateway in the dialog box for this
    > purpose (Mine is set at 192.168.168.168). Check the box entitled "Automatic
    > Metric", if you do need to add a default gateway.
    >
    > To look at the bindings in Win98, click on "Start", then "Settings", then
    > "Control Panel", then "Network", hi-light each protocol involved, then click
    > "Properties", then click on the "Bindings" tab on top. For instance,
    > hi-light the the "IPX/SPX compatible transport protocol", click on
    > "Properties" and then click on the "Bindings" tab on top and ensure that the
    > box next to each of "Client for Microsoft Network", "File and printer
    > sharing for Microsoft network" and "NETBIOS support for IPX/SPX compatible
    > protocol" is checked. While you're there, click on the "Netbios" tab on top
    > and ensure that the box next to "I want to enable Netbios over IPX/SPX" is
    > also checked. On each Win98 machine, do not forget to unbind the TCPIP
    > protocol for LAN traffic. To do this, hi-light the "TCPIP protocol", click
    > "Properties", click the "Bindings" tab on top and ensure the box next to
    > "Client for Microsoft Networks" and "File and printer sharing for Microsoft
    > Networks" is unchecked. Once you do this, you will get a dialog box stating
    > "You have not selected any drivers to bind with. Would you like to select
    > one now?", click "No". While you're in the "TCPIP Properties" dialog box,
    > click on the "Netbios" tab on top and ensure that the box next to "I want to
    > enable NetBios over TCPIP" is unchecked. You might also want to configure a
    > default gateway by clicking on the "Gateway" tab on top.
    >
    > I'm not using NetBeui as IPX/SPX seems to work adequately in XP for File and Printer sharing on my > LAN.
    >
    > I hope this helps! For an OS that's supposed to be so great at Networking,
    > XP requires all of us to become instant experts in Networking, which is way
    > too much for your average users, including me, before I installed XP.
    > Necessity is the mother of invention!
    >
    > Best of luck to all!!!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.