TechSpot

Home Network demands (unknown) Password to connect

By marine105
Apr 2, 2006
Topic Status:
Not open for further replies.
  1. I have a peer to peer home network. Main PC runs with XP Home. Client runs with W98SE. From the XP machine I can access files on the W98.

    On the W98 machine, in Network Neighborhood when I click the icon for the XP machine I get a message
    "You must supply a password to make this connection
    \\computername\IPC$"
    On both machines I am logged in with the same User Name & Password, but this password is rejected.

    I can ping the XP by name so no probs with the hardware. Please can someone put me right?
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    You have to remember XP home cannot join a Domain.That means the 98 machine will always have to logon to a "Share" on the XP machine.
    The 98 cannot deal with the security settings of NTFS especially.
    Choose a folder on the XP machine and make it a Share , you can map a drive to it from the 98, but you will still have to enter username and password(Windows will bring up this window,so click on remember password)
    It is often best to run the network Wizard on XP after it is set right let it make a floppy for you and run the floppy on the 98.
    I take it you have a good firewall,you are very exposed without a router .
  3. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Sounds a possibility, but you'll need to hold my hand onthis one! How do I map a drive to the Shared Folder from W98 if I cannot access XP without a password?

    I take it you mean I should run the Network Wixard again after these steps: I already ran it once.

    Yes I have Zone Alarm, but as yet obviously have not been able to access the internet from W98
  4. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    You run the Wizard if you make changes in the Network settings particularly on the XP machine ,especially if you have trouble connecting afterwards.
    You should be able to connect to the share on XP (You make it First), and if you do you will be able to Map it from 98
    If you cannot connect to it then there are some other problems.
    Let us know after you try.
    P.S. Good you have ZoneAlarm Make sure you have each machine registered in the firewall as a Trusted site
  5. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    OK, I set up a new folder on XP, named it Test, and enabled it for sharing, but I still get the password demand on W98.

    Yes both machines are Trusted Sites in Zone Alarm.

    PS Why can't I see the Quck Reply icons?
  6. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    You have some setting wrong in XP I unfortunately have to leave .I will be back in a couple of hours.I will check in then,and walk you thru, if you still need help. In the mean time do a search here for XP 98 netwrks it's here.
    Pay attention to 98 netwrk logon types there are 2 .checkfor affects from " simple filr Sharing" and XP "file Print sharing settings".
    Also do you have the same Workgroup name on both machnes , it will default to MShome or something every time you run the Wizard.

    P.S. I think those settings for the Quick Reply are in your PROFILE setup pages.
  7. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Are you using a Crossover cable , between the XP and 98 machines?
  8. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Sorry, GMT intervened! Found the Quick Reply button now.

    #7:Yes, I have crossover cable as the link.

    #6:
    did you intend to include a link to another site? It didn't appear so I haven't been able to do the search.
    However, I've done a bit more checking and am not convinced I have the User Names set up properly but cannot see how to correct the situation. Let's assume I am John Smith, password: numbskull. I log into Windows on XP with this, and if I check with Start/Run/cmd, I see : C:\Documents & Settings\John Smith.
    Then I log into W98 with same name & password. I have to do it twice, first for Windows, then for Network. I believe the W98 equivalent check is Start/Run/Command? This gives me C:\WINDOWS.000\desktop

    Yes I do. I've noticed the annoying habit of reverting to MS HOME so am alert to this although surely running the Network setup disk on W98 would make the network names the same even if not the names I wanted?
  9. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    I meant for you to try the search button at the top of this Page.Try it each you come with issues, you will find you can get faster answers there.
    I am sure you know that Win 98 cannot read NTFS disks and so you have a Fat 32 partition on that XP machine ,Right?

    ""Then I log into W98 with same name & password. I have to do it twice, first for Windows, then for Network. I believe the W98 equivalent check is Start/Run/Command? This gives me C:\WINDOWS.000\desktop """

    This is the way it is in 98, if you want to have just a little security, albeit easily defeated security.

    P.S. You might want to use one word Names for your users. many system and program processes get fouled when there is a Space in names (Dos based Rules)
  10. kirock

    kirock TS Rookie Posts: 1,598

    May I make a suggestion? To avoid the whole NTSF and FAT32 issue why don't you upgrade the 98 machine to XP. You can do this right over top of the 98 OS and convert to NTSF at the same time. I did it to my kids machine and now have ICS working just fine. Hint, you also have to turn off the Firewall on the internal LAN connection at the XP machine (in your case). Control Panel/Network Connections. Right Click on the LAN icon that goes to the 98 PC/advanced tab.

    Just a thought.
  11. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Found nothing under Search.

    #9:Confirm I have FAT32 on XP machine.
    #10:Upgrading W98 to XP is not an option for a number of reasons. If it had been, I'd have tried it.
    #10: Confirm Windows Firewall is off.

    #9: So you don't think there is an issue in the User Names setups. I'm very reluctant to change the user name on XP. I have tried this (to a single word) but couldn't work out how to change the names of My Docs without having to re-enter all my personal stuff. I'll have another go if you think this may be the root of the problem: otherwise where do we go next, please? Just to be clear, I still get the password demand from W98 as detailed in #1
     
  12. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    A single word user name only refers to the Logon Name .You do not have to touch My Docs or anything else.
    Right click on My computer>Manage>Local user&Groups>users> Here you will see a name in the first column ,this is the name that is displayed at logon.You can change this by right clicking >rename. Do not change the name in the Second column (FullName)
    You do not have to do this I was only giving you a fact.Just make sure you have the same username -Password and Workgroup name on both machines.

    As for your Network.I am not so quick with XPHOME, bear with me. Home just cannot network well enuf for my needs, I haven't used it in a few years.
    Home uses Simple file Sharing ,you should be aware that XP will enable the Guest(Easily Exploited) account in order to share files .Check to see if the Guest account is not disabled.>
    Right click on the Drive where you want to place the shared Folder (If possible do not use C:\)
    On the Sharing tab Click on the" You understand....share this Drive Click here"
    The next window should be Property for a folder and you simply Click to Share this Folder ,Giv a Share name , and Allow network users to change my Files. >
    This Folder should be in Explorer under Shared Docs.
    You might have to reboot after all this , and be patient when you get back to try and logon from the 98 it can take up to ten minutes for computers to first find each other.
    You want to Dbl click on the shared Doc Folder listed in " \\98\explorer\network neighbourhood\XP\Shared Docs\"
    If you cannot something is wrong and you may have to start from scratch.

    P.S. Although you can test this breifly with your Firewall off Do Not leave it Off, it should allow Sharing if both computers are listed in the Trusted Zone.
    Which reminds me you may have better success with Fixed ip addresses on the machine , but that is a different converstion.
  13. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Thanks for your efforts. Here's what I did this morning:
    Reconfirmed same name & password logged in on both machines
    Checked Guest Account: it was not enabled, so I enabled it.
    Had to use C Drive (understand eventual security risk, but let's solve the problem and worry about security later). Set this up for sharing and ability to change files.
    Test Folder is in XP's Shared Docs Folder.
    Rebooted XP, even though it hadn't asked me to.

    Regrettably on W98\explorer\network neighborhood, there is still only XP itself showing (no Shared Docs Folder) and clicking on this brings back the password demand.
    I tried again with Zone Alarm fully disabled, and still no luck.
  14. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Do your Computers have their own Names?; In 98 this will be ControlPanel>Network>Identification tab,Give it a name ( one Word,not your username)
    Also,lets be sure you have one password in 98 Go >ControlPnael>Passwords>Change passwords ,There are two Windows PW and Change otherPW , You want to make them both the same .
    Remember you must reboot to make most System changes in 98.

    Next you said that when you clicked on the XP icon in Network neighbourhood from the 98 machine you got asked to input a PW,You are
    ALWAYS going to have to do that if you use XP Home Each time you logon to a Share .I can send you a Batch file that will do that(logon to Shares) for you from a Shortcut on the Desktop, later.

    The fact that XP had not enabled the Guest account means, when you ran Network Wizard you Did /didnot make some selection .However since you can see the XP icon in 98 is good.
    Trouble shoot Time.
    Check Right click My computer>Manage >Services and Appli...>Services and confirm ICS service is running.If not Right Click and Start it > test connection

    You have two Ethernet Connection in XP right(one to IP, two to 98)?
    You may have run ICS Wizard to share wrong Card,(You can Name these connections to distinguish them apart)

    Can you connect to the internet from 98?

    There is one setting in 98 that way help;ContlPanl>Network icon>Client for Microsoft Netwrks>Properties- Click "Log on to Windows Nt and put XP name in the Box(This is really for NT Domains but it may help.

    i will check back if you still are not up I will step by step the ICS wizard for you.
  15. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Confirm each PC has its own name: these were set up by the Network Setup Wizard along with the network name.
    Confirm there is only one password registered on W98.
    I'm happy to enter a pw to log on from W98 to XP: my point yesterday was that I still don't know what the pw is!
    Network Setup doesn't ask you about enabling the Guest Account.
    One other thing I found yesterday: I can transfer data from XP to W98 and vice versa so long as I sit at XP. XP could always access and amend W98's files: to send data from XP, I can drag & drop it into W98's shared folder then move it from there to the final folder. Not 100% ideal but it shows I have good connection and it's far better than messing with floppies. So the key issue I want to address is to be able to access the internet from W98.

    Now:
    Services & Applications/Services brought up a list in the pane to the right. There was nothing named ICS. The nearest was IPSEC Services (manages IP security) and this is started automatic.

    Yes, 2 separate connections, one to Internet and one to the LAN. I am happy the wizard ran on the correct LAN connection.

    No, as said above I cannot connect to internet from.W98.

    Finally I entered XP's name in the NT domain box. I rebooted as asked and after entering my Windows pw got "No domain server was available to validate your password. You may not be able to gain access to some network resources". This came up again after the netowrk pw. Shall I undo this action?

    It still puzzles me that there is only one same pw in use on both machines, yet this is rejected by W98 when I click on XP's icon.
  16. Spike

    Spike TS Rookie Posts: 2,371

    ICS is "Internet Connection Sharing"

    The service name is "shared access", and it's display name is "Windows Firewall/Internet Connection Sharing (ICS)"
  17. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    There's nothing called "Shared Access" under Services & Applics/Services.
    I have Windows Firewall disabled.
  18. Spike

    Spike TS Rookie Posts: 2,371

    Shared access is the proper service name, for use at command lines.

    under the services list, you need to look for it's display name!!!! Windows firewall/ICS. It's combined into the same service.

    Enable the service, and turn off the firewall in Control panel.
  19. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,646

    Marine.. Quote"
    Finally I entered XP's name in the NT domain box. I rebooted as asked and after entering my Windows pw got "No domain server was available to validate your password. You may not be able to gain access to some network resources". This came up again after the netowrk pw. Shall I undo this action..."

    You can Back out of this As I stated it might only work in XP Pro.

    You can try Control Panel > Network AppAccess control tab> try the setting for "User level Access" put the XP name in the box REboot remember to give it a few minutes and try a few times .

    Going to work and will look in Friday night.
    The fact that 98 cannot see internet convinces me that the trouble is at XP it controls ICS and becomes a server for Net distribution.
    It is also possible you have a bad ethernet card.You can test it by reversing the roles. Detach the 98 and reconfigure that card to go online on XP> go direct online thru 98.I know it is some work but if all else fails.
    I would re-install all network configuration Starting with ICS wizard before the Hardware test.
    I will walk with you if you want.
  20. marine105

    marine105 TS Rookie Topic Starter Posts: 26

    Tried this & got "Windows couldn't find the specified security provider on the network. Do you want to use the name anyway" so I did, but after a couple of delayed reboots was still denied access to XP, so I've reverted to Share Level Access Control. Also undid the NT Domain box.

    I don't feel comfortable with configuring XP's ethernet card to go online: I'm worried about not being able to get back to how things are now! I have however (yet again) reinstalled both card drivers. On each machine the Hardware config says they are running OK, and I can ping both ways by name. I have re-run the Network Set Up Wizard, made a new setup disk and run that on W98. I now get "XP not accessible. No permission to access resource". i.e. I'm not asked for a pw but still can't access XP from W98.

    Also I tried enabling IPX/SPX on both machines using procedure posted in topic 28045. After doing all this, I lost all ability to transfer data and couldn't ping either way by name, only by IP address. So I disabled IPX/SPX and reverted the bindings to TCP/IP and I'm back where I started.

    Otherwise nothing has changed: I can still fully access W98 from XP and transfer data both ways provided I sit at XP.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.