TechSpot

How do you access "Program Files" folder on a network?

By fireflysydney
Nov 16, 2005
Topic Status:
Not open for further replies.
  1. My network has 2 PC's, one of which had XP installed when purchased. The other had Windows 98, and has been recently upgraded to XP. I want to be able to access any file from either machine. On the PC that was upgraded from Win 98, I have set Drive C to be shared. The other PC can access any file, including those in the Program Files folder. It can, for example, run PaintShop Pro across the network, even though it's not installed on that machine.

    I have set Drive C on the other PC to be shared, but I cannot access its Program Files folder from the (former) Win 98 PC. I get "Access Denied" messages.

    Does anyone know how to allow complete sharing of all files?

    Thanks
    FireFlySydney
  2. Nodsu

    Nodsu TS Rookie Posts: 9,431

    You need to set both share permissions and the file permissions on disk.

    No need to specifically share the drives BTW. Windows automatically enables administrative shares in the form of c$ d$ etc.
  3. Samstoned

    Samstoned TechSpot Paladin Posts: 2,582

    try mapping the drive for faster access
    add a new share give it a special name
    for the drive setup how many users at one time
    add network and administrator then delete ( all users )
    delete the C$ share this can be a security risk
    under network user add permissions same with admin
    you can later setup password timeouts/expires
  4. fireflysydney

    fireflysydney TS Rookie Topic Starter

    Trying to access "Program Files"

    I've already set up the sharing. I've made Drive C on 'fairyfloss' a shared drive, and 'excalibur' can access most of Drive C. But it can't access anythnig in the "Program Files" folder. Windows XP specifically prevents you from making the Program Files folder a shared resource. But there must be a way to do it, because I've set the same sharing permissions on 'excalibur', and 'fairyfloss' can access any folder, including Program Files, without getting 'Permission Denied' errors. The only difference between the machines is that 'fairyfloss' was installed with Windows XP when purchased, but 'excalibur' was recently updated to Windows XP from Windows 98.
  5. moxlon

    moxlon TS Rookie

    Accessing "Program Files" from a LAN / fixing "missing" User accounts

    Recently I was asked to find a way to restore access to "Program Files" from a network share for a customer of mine. I used to access program files from my lan at home, before SP2 came out, so I'm not sure when "Program Files" became a restricted directory.

    I did a bit of research, and read a solution suggesting to use "control userpassword2", which, in my personal experience, broke the user account on XP Home. Now, I can't access the user account, and, for all intents and purposes, Windows XP thinks that the account is missing. You cannot modify the account from the User Accounts panel, and the account is missing from the login screen. I opened a command prompt (start > run > cmd) and typed the following commands:

    net user listed the account as still being on the system
    net user (username) listed the account has having no 'Groups'
    net localgroup produced a list of local group policies on the machine.

    to fix the broken account, using the info I just got from the previous commands, I typed;
    net localgroup Administrators (username) /add

    The account was an administrator account, so, I restored the Administrators group to the user account, and presto. Windows now recognises the account as a fully functional user account.

    The next suggestion that I saw for fixing "program files" has to do with the way Windows allows access to network shares. Under XP Home, specifically, network shares are all accessed via the Guest account. I'm not sure about XP Professional, most of my customers have XP Home.
    For this example, we'll just say that the groups consisted of *Administrators, *Guests, and *Users as listed by net localgroup.

    The suggestion that I read suggested that the user add "Administrators" to the Guest account, but cautioned that this was not recommended.
    Normal users (non administrators) have access to program files though, so, my solution, which seems to work fine, was to add Users to the guest account. I'm sure this isn't the best, or most secure solution, but it does work.

    net localgroup Users Guest /add

    then I exited the command prompt, and rebooted the computer.
    I went to one of the other lan machines, and tried to access program files again from across the lan. Now, the networked machines have access to the program files directory.

    While I know I am not an expert, and that there are probably better solutions to the problem, this solution does not involve registry editing, and is straight forward. I hope that this information will help users who accidentally deactivate user profiles, and those who wish to access "program files" on their local networks.
  6. kochese

    kochese TS Rookie

    This is the key.
    cacls.exe is the command that changes Access Rights.
    1. open a command window by clicking on Run and entering cmd, click OK
    execute the following commands
    2. cd \Program Files
    3. cacls will display the help screen with different options
    4. cacls . /T /E /G Administrators:F will allow full access to the Administrators group to Program Files and subdirectories
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.