How to decrease xp shutdown time?

By escaflownev1
Jul 26, 2007
  1. My computer used to shutdown in approximately 30-35seconds, but just recently it has greatly increased that time. It takes around 6-8 minutes. How do i fix this problem? I have already scanned for spyware and viruses, and it has not helped.
  2. Po`Girl

    Po`Girl TS Rookie Posts: 595

    1.If you have Norton/Symantec,uninstall it,and get a sensible AV/Firewall

    2.Go to Start/Run/type: msconfig loook for the Start up tab,and then uncheck everything except Firewall.
    Then restart and try shutdown again.

    3.Uninstall the program you most recently installed.

    4.If you have a suitable System Restore point,try that.

    5.Make Windows kill processes instantly :

    Click on Start/Run.

    In the Run text box, type regedit and then click OK.

    In the Registry Editor, navigate the following branch-

    HKEY_USERS\Default\Control Panel\Desktop

    On the right panel , search for AutoEndTasks registry key.

    Double click on the key and modify the Value data to 1.

    Click on OK when done.

    Restart the Windows, the change will be effective.

    Warning: Modifying the Windows registry may cause your computer to stop functioning. Backup and handle with care.

    To undo the changes, just change back the Value data of the Registry key to 0.

  3. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    That's a cool registry tweak ... I'll have to remember that one!

    Cheers :grinthumb
  4. escaflownev1

    escaflownev1 Topic Starter

    i've done this but the shutdown part that takes long is after the desktop has already exited. The saving your settings window, and windows is shutting down is what take all the time.
  5. Po`Girl

    Po`Girl TS Rookie Posts: 595

    Did you try the system restore option ?

    Try disabling Windows logon screen.
    That`s the only other thing,I can suggest.
  6. escaflownev1

    escaflownev1 Topic Starter

    Yes i have tried system restore without any gain. Has anyone heard that it could be a power problem, too many things plugged into same outlet. I heard that and unplugged somethings and it seems to have helped. Is this just wishful thinking?
  7. Po`Girl

    Po`Girl TS Rookie Posts: 595

    Ok two more -

    1.Microsoft has something HERE Not sure what it is,but try it anyway.

    2.Make sure clear pagefile at shutdown is not enabled -

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    Set ClearPageFileAtShutdown value to 0

    Or, using Group Policy Editor [for Windows XP Professional]

    Click Start, Run and type Secpol.msc

    Click Local Policies | Security Options

    In the right-pane, set Shutdown: Clear virtual memory pagefile to Disabled
  8. escaflownev1

    escaflownev1 Topic Starter


    thanks for the microsoft link, but i have already tried that before and it hasn't helped. Also i dont even have a paging file, and either way it is set not to delete it at shutdown. I giving up on this problem unfortunetly.
  9. gbhall

    gbhall TechSpot Chancellor Posts: 2,423   +77

    maybe NOT having a paging file is the true cause? Unless you have real reason, I would have a paging file, if Windows doesn't need it, it won't use it, so where is the loss?
  10. matav

    matav TS Enthusiast Posts: 144

    hey, turn off your system restore.
    disable it... ****all previous restore points will be deleted!
    system restore keeps saving copies of ur recently used apps and files... check it in F1..."Help and Support Centre"
    personally i feel This slows down your computer as well as eats up HD space.
    besides this
    maybe u must have installed a p/g that must be locked or not responding to the shutdown command and must be remaining in the memory... the OS then tries to kill this app, but cant, so it keeps trying.
    find this app thru ur taskmgr by ending most *known-but-not-sysem'
    also keep ur start-up list tidy.
    try this too: it may/may not work, i havent had ur problem yet.
    go to control panel>User Accounts>Change the way a users logs on or off... now uncheck "Use Fast User Switching"
    learn more about it in F1..."Help and Support Centre".
    post ur HijackThis Log.
  11. matav

    matav TS Enthusiast Posts: 144

    nah! this wont help ur shut-down speed... instead by enabling that option, it will increase ur start-up speed.
  12. matav

    matav TS Enthusiast Posts: 144

    paging file also called swap file, n is quite necessary...
    u must be having it... check:
    my computer>properties>advanced
    under performance click on settings and go to tab "advanced"
    check the bottom... is there a "Virtual Memory" message?
    there we can configure the paging file.
    nywy since you dont dual-boot, u need not empty the page-file before shutting down.
    if enabled... it takes a toll on the shutdown time required.
    learn more about it in F1..."Help and Support Centre"
  13. olefarte

    olefarte TechSpot Ambassador Posts: 1,343   +6

  14. escaflownev1

    escaflownev1 Topic Starter


    i wish it was, but its not. after all i said this is a new problem. I have had paging file disabled for much much longer than this problem.
  15. escaflownev1

    escaflownev1 Topic Starter

    Thanks! Problem Fixed

    Hi, thanks everyone for trying to help me fix this problem. I finally was able to fix this problem. I disabled my diskette drive and my parrallel ports in bios. In bios I also set the serial port to be managed by the os. Now my computers shutdowns faster than ever. It takes less than a minute.
  16. BlameCanada

    BlameCanada TS Rookie Posts: 320

    Wow ! Where did you dig those fixes out from ?
  17. escaflownev1

    escaflownev1 Topic Starter

    I didn't find them anywhere lol. It was guess work, and thankfully it was helpful. I just disabled devices that I wouldn't use.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...