TechSpot

How to get file permissions

By ColdFusion1990
Jul 17, 2007
  1. I really need to delete a certain file in my computer which requires permission to delete. I am using the only account on the computer. How can I get permission to delete my own files?
     
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

  3. TheWatching

    TheWatching TS Rookie

    What Operating System are you using? You can gain access to the permissions in Windows XP Pro if you disable simple file sharing. In a standard window go to tools -> Folder Options -> View -> Scroll down to the bottom and uncheck the box that says "use simple file sharing" Apply and OK.
    Now you can right click on a folder and go to the security Tab. You can manipulate permissions from here.
    XP home has no such interface....

    If this is a problem with a file that runs at boot with the logon process then you will have to use a boot disk to get into command console. And use the delete command to delete it from the desired directory.

    Hope this helps.
     
  4. ColdFusion1990

    ColdFusion1990 TS Rookie Topic Starter Posts: 124

    I am using windows vista business 64 bit edition
     
  5. zipperman

    zipperman TS Rookie Posts: 1,179   +7

    TheWatching is probably right.It seem you didn't even try.
    vista will have this option.
    Use help and support to find out how.
    Type in File shareing.
     
  6. zipperman

    zipperman TS Rookie Posts: 1,179   +7

    BTW,what is the name and location of this worysome file ?
    What problem(s) does it cause.
     
  7. almcneil

    almcneil TS Guru Posts: 1,277

    I presume you checked the file's permissions in Windows Explorer. If not, right click on it, select Properties, see what it says. If it's read-only, remove the checkmark. Sorry if I'm being overly simplistic, it's hard to tell from your posts what the exact problem is.
     
  8. raybay

    raybay TS Evangelist Posts: 7,241   +9

    You can usually do this by booting to Safe Mode as well. The above suggestions are good ones that normally work.
     
  9. ColdFusion1990

    ColdFusion1990 TS Rookie Topic Starter Posts: 124

    While re-installing my OS (Vista), my old User file was accidentally copied into my hard drive with the new User files. The User file is taking a lot of unwanted space. I went to the Advanced Security Settings to get permission, and it says I have full control of everything. When I tried to delete it, it still wouldn't allow me to do so because I still don't have permission. The file also isn't being shared at all.
     
  10. TheWatching

    TheWatching TS Rookie

    I am trying to remember with Vista, where you need to go...but I think I understand your problem now.

    You need to take ownership of the files. In XP that was an option that was available when Simple File Sharing was disabled.
    You could then right click on the file, choose properties, choose the Security Tab and then go to the Advanced Button below. Then you will find the Owner Tab.
    If your user name is in the user list box then you can highlight your name. Make sure you check the box to replace owner on container and sub containers.

    I hope you can find similar options in Vista.

    Hope this helps.
     
  11. almcneil

    almcneil TS Guru Posts: 1,277

    Ray's point is excellent as I sometimes forget this myself. If you're having a sticky problem with something that should be routine, try going into Safe Mode. I recall a customer who was having a problem deleting a user account. We went into Safe Mode and then were able to do it. Sometimes in Windows you hit a glitch but Safe Mode uses only a subset of the build. If there was a conflict with an optional component, in Safe Mode that conflict will not exist.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...