TechSpot

How to install 7600 GT

By justinone
Dec 27, 2006
  1. OK this is a realy dumb question but im not sure if i have installed this right.
    I'll go through what i did in steps:

    1: Removed old ATI Drivers, turned pc off, removed ATI card.
    2: inserted my XFX 7600 GT into place, connected the power dongle from PSU (I just connected it to the first free plug i found)
    3: Turned pc on, inserted CD, installed driver from cd (didn't install TV Capture if this is important? it would not let me), pc restart.
    4: Downloaded lastest drivers from Nvidia site, installed, pc restart (XFX Drivers give me an error)
    5: Installed personnal cinema (if this makes a difference?)

    right? or wrong? i dont know why the XFX driver wont install :S it comes up with this error upon starting install "The NVIDIA setup program could not locate any drivers that are compatable with your current hardware" even though i entered my cards serial number on the XFX site and it directed me to download that driver?

    When i go to install TV Capture, it tells me "to go to www.xfxforce.com for the optimized driver" and i cant find that anywhere :S.
     
  2. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    Did you uninstall the drivers for the ATI card prior to inserting the 7600 GT and installing those drivers?? This could cause a conflict in the INF file of Windows.
     
  3. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    The way I read it, you installed two sets of Nvidia drivers one on top of the other. You should have uninstalled the first one before installing the second. It would have been better to have downloaded the latest Nvidia driver in advance and just used it instead of the CD version.

    Try uninstalling all of the Nvidia graphics card drivers and reinstall the one you want. Just as a word of caution, if you have a motherboard that has an Nvidia chipset, don't confuse the Nvidia chipset drivers for the Nvidia graphics drivers and uninstall the wrong driver.
     
  4. Grafficks

    Grafficks TS Rookie Posts: 302

    Yes it does sound like you tried to install two versions of nVidia graphics driver without removing the first.

    In step #3 you say you installed the drivers that came with the CD, then in step #4 you say you downloaded and installed the latest nVidia driver, with no mention of having removed the previous ones.

    The latest driver (93.71) is found HERE.
    And the Installation Hints for it say that:
    And those would be your instructions. Good luck.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...