How to make Media Player the default player for video, NOT Quicktime

By troxartas
Jul 8, 2006
Topic Status:
Not open for further replies.
  1. Hello everyone, I have a problem with Quicktime right now. I really would like Media Player to be the default player for .mpg and .wmv, but even though I have Mozilla set in the options screen to open those programs with Media Player, they are still opening in Quicktime! I also went to the plugin settings screen in QT and set it to NOT be the default player for video files (unless they're .mov). After I did this, those video files i told mozilla to open in MP are still being opened in QT! Am I doing something wrong? Any help will be appreciated, thanks!
  2. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Click start/all programmes/set programme access and defaults. Click the custom button and under choose default media player, check the windows media player button and click ok.

    Regards Howard :)
  3. fastco

    fastco Newcomer, in training Posts: 1,511

    Have you tried going to My computer, tools, folder options, file types then scroll down to each media type ie: wmv, mp3 and click change then pick Windows Media Player for each of the files and OK your way out.
  4. fastco

    fastco Newcomer, in training Posts: 1,511

    Sorry again Howard..
  5. troxartas

    troxartas Newcomer, in training Topic Starter Posts: 33

    unfortunately, neither of your suggestions worked.....is that strange?
  6. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Ok, try this.

    Go to your control panel and open the Qucktime icon.

    Click on the filetypes tab and untick everything, click apply/ok.

    See if that helps.

    Regards Howard :)
  7. troxartas

    troxartas Newcomer, in training Topic Starter Posts: 33

    I just unclicked everything in quicktime and mpg are still opening in quicktime. this is strange i think!
  8. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    Did you click on the little plus signs next to the file types? This opens up the specific file types and you can disable them from there.

    Regards Howard :)
  9. troxartas

    troxartas Newcomer, in training Topic Starter Posts: 33

    yes i did that....
  10. troxartas

    troxartas Newcomer, in training Topic Starter Posts: 33

    this is very strange....does quicktime have a bug or something?
  11. Peddant

    Peddant Newcomer, in training Posts: 1,644

    Quicktime is a bug.Uninstall it, re associate files with WMP or Winamp.

    Reinstall QT if you have too,but don`t let it grab any associations.
     
  12. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    I don`t know about Quicktime having a bug, but it`s a complete pain in the backside at times.

    I forgot to mention that after you have disabled the filetypes in Quicktime, you will probably need to follow the instructions for the setting programme access and defaults. With that in mind, I suggest you do it all again, I.E disable the Quicktime filetypes, click apply/ok, then before trying to open any media files, do the default programme access and settings.

    The only filetype that automatically opens in my Quicktime, are Quicktime movies.

    If that doesn`t help, try uninstalling Quicktime. Then reboot your computer and reinstall it. Set your preferences during the installation.

    I wish websites would stop using Quicktime altogether.

    Regards Howard :)
  13. troxartas

    troxartas Newcomer, in training Topic Starter Posts: 33

    will itunes work if quicktime is uninstalled?
  14. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +19

    As far as I`m aware, no it won`t.

    Regards Howard :)
  15. Peddant

    Peddant Newcomer, in training Posts: 1,644

    Three of my googles said it would affect itunes and one said it wouldn`t.

    Don`t forget,that you can right click on a file,and select "open with" and
    "always use this program"

    I also found this tip -

    When you have got your file associations as you want them go to

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes. Choose File,Export.

    Export to desktop.Then when you need to restore associations just double click that file.
  16. troxartas

    troxartas Newcomer, in training Topic Starter Posts: 33

    right clicking and choosing "always open with...." does not work.....i would try the HKEY thing, but i don't know how to go about it, could you enlighten me please? i'm still a novice at this stuff! Thanks.
  17. Peddant

    Peddant Newcomer, in training Posts: 1,644

    I don`t know why "open with" doesn`t work.There`s a page HERE that explains what you have to do.
    Windows Media Player should be one of the options in the menu.If it`s not you`ll have to browse to
    C:\Program Files\Windows Media Player\wmplayer.exe

    As for the registry key,that is only something you might do when you have all your file assocations as you want them.
    It is a non essential tip.You can read about it HERE

    You shouldn`t really have to do any of this.The suggestions earlier in the thread would normally suffice.
    Uninstalling QT,then reassociating files with WMP,then reinstalling QT would be my suggestion.
  18. 13636712

    13636712 Newcomer, in training

    prevent quicktime from opening mpg within browser

    That's easy... "mpg" is more akin to an MP3 than it is to an MPEG-2 video... you would think since its video, media player would open it... but Quicktime hijacks it because you set your Quicktime MIME types to open MP3s (and therefore mpg)...

    Let me guess.. you already opened quicktime and within the preferences unchecked all the MIME types except for MP3s because you use iTunes (and the only reason you still have quicktime is the nazis at apple force you to have quicktime in order for itunes to work)...

    plus, let me guess that in Mediaplayer->Tools->Options->Filetypes you *unchecked* MP3 becuase you want iTunes to handle that... well... that's the problem.

    you have to have MediaPlayer the default player for MP3s... this will change the icons on MP3s... but your iTunes will still play all the MP3s in your playlists... THIS SHOULD FIX YOUR PROBLEM...

    You can also do the following in prevent Quicktime from hijacking other things.

    First set a restore point.

    Then go to:
    C:program Files\Quicktime\plugins
    --> change the name (don't delete) all the plugins that start with "n"... add a new letter or something..."npqtplugin.dll" to "wnpqtplugin.dllll"

    C:program Files\Internet Explorer\PLUGINS
    --> change the name (don't delete) all the plugins that start with "n"... add a new letter or something..."npqtplugin.dll" to "wnpqtplugin.dllll"

    **NOTE: you must change the plugin names AFTER you have changed the MIME types in the traditional way... because Quicktime will refresh all the plugins in the above two locations every time you go to the Preferences tab.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.