How to remove 2nd XP option on startup

By scumbag
Jan 8, 2006
  1. I've recently installed another version of XP Home on my computer & now when I boot up I get the option to choose which version I want, both of them being XP Home.

    I get 30 seconds to chose before it choses for me.

    The 1st option works, th second doesn't.

    How do I remove the 2nd option?
  2. Peddant

    Peddant TS Rookie Posts: 1,446

  3. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    i would not change it to 0
    the boot option should show the 2 places where the OS's are at
    you fig out the one you want to save and delete the other option just think a minute and you will see the logic
    if you are feeling a litle scared about it do search on MS's website and you will find an example of the OS boot.ini file
    you have to untick read only to edit in txt editor
  4. scumbag

    scumbag TS Rookie Topic Starter Posts: 18

    Yeah, that's all for Win2000 though.

    There's a bloke at the bottom of the thread who asks the same question as me but there's no answer.

    I've tried looking for "c:\boot.ini" but can't find it.

    Isn't there an easier way? It seems like a simple enough problem.

    Thanks for all the suggestions anyway :)
  5. Peddant

    Peddant TS Rookie Posts: 1,446

  6. s3xynanigoat

    s3xynanigoat TS Rookie Posts: 94

    Start < Settings < Control Panel < System < 'Advanced' Tab < ON this tab there is a "Startup and Recovery" field, Click the 'settings' option here. < Under "System Startup" field there is an 'Edit' button. Edit out the first Win Xp copy, and "cut and paste" the second copy into the "default=" space.

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
    multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

    [boot loader]
    [operating systems]
    multi(0)disk(0)rdisk(1)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect
  7. wlknaack

    wlknaack TS Rookie Posts: 143

    If the original boot path is now invalid, here is another way to eliminate the OS option screen: Start/Run/type "msconfig" in the dialog box, without the quotations. Select the boot.ini tab in the System Configuration Utility and click the "Check All Boot Paths" button. If the original path comes up as invalid, choose the delete option. Click Apply and OK and reboot your computer. The OS option screen will no longer appear.
  8. scumbag

    scumbag TS Rookie Topic Starter Posts: 18

    Hi again,

    These last 2 posts have been really helpful, unfortunately cos i'm an ***** i just the wrong one to delete & f****** up my PC big time :-(

    I've just reinstalled windows & I've gone to the Boot.ini. menu but it's still showing me 2 XP Homes.

    Which one do I delete?

    When my PC boots up it's the top choice that works, does that mean I delete the bottom one?
    Logic would say so but I just want to make sure.
  9. wlknaack

    wlknaack TS Rookie Posts: 143

    When you reinstall Windows XP, the OS choice screen will still appear and show not only your recent OS install, but also the old install even though you have deleted it. Go to the configuration utility as I explained in my previous post and delete the boot path that is found to be invalid.
  10. scumbag

    scumbag TS Rookie Topic Starter Posts: 18

    Nearly got it licked Wlknaak, When I check the boot paths it gives me an option to delete one, which I do.

    I hit "apply" & restart but the PC restarts in "selective startup" which I don't want.

    When I change it back to normal startup in the "General" tab then it reverts to the original boot ini.

    How can I delete it without having to start up in selective startup?

    I think we're nearly there :), Thanks for the help so far.
  11. wlknaack

    wlknaack TS Rookie Posts: 143

    To WinXP, when you reinstall the OS, the boot path is modified. So it directs you to the Selective Startup. Make sure all options are checked in Selective Startup, and have the "Use Modified Boot INI" selected. This is, by definition, the same as the normal boot mode.
  12. scumbag

    scumbag TS Rookie Topic Starter Posts: 18

    Right, I tried that & it seems to be working fine.I just worried that it was something like safe mode & wouldn't let me do certain things.

    You fixed it mate!
    You're a wonderful person :)
  13. wlknaack

    wlknaack TS Rookie Posts: 143

    Glad to see everything is OK!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...