How to share a printer on a network?

By zaahidkhan
Jun 9, 2005
Topic Status:
Not open for further replies.
  1. i have tried everywhere for this, but they all seem to give me the same standard reply as what windows recommends.i have a windows xp computer with a printer connected to it. i have also got another windows xp which does not hav a printer connected to it but i want to share the printer on my other computer. i use a netgear dg834 broadband router to share my broadband internet. how do i share the printer though? everywhere keeps saying make sure prinet connected to the pc is set to share, and then add printer from other pc, but it does not find any printers?? help me please :giddy:
  2. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Alright, XP does make it a bit easier. Do you have XP Pro? Cause pro may have some more steps to take.

    Right-click My Computer on the host (PC with printer) and then click Properties. Next click the Computer Name tab. Look at the Workgroup name, write it down. Also make note of the "full computer name". Go to this same place on the client PC (other one) and if needed, click the "Change" button to put it on the same workgroup.

    Next open My Computer. Then click Tools-Folder Options. On the host PC. Go to the View tab and scroll to the bottom of the list and see if there is a check mark next to an item called "Use simple file sharing". If so, uncheck it. May not be needed, but not sure.

    Now go into Control Panel-Printers on the host. Right-click the printer and choose the sharing option. Check that the share name is nice and small and that the appropriate permissions are set to allow access.

    During these operations, you may be required to restart, that's fine.

    If you have done all these and still can't connect to the share, then it is likely a firewall problem. Since you have a router (which should also be a firewall), make sure neither computer has a software firewall running. Check your Antivirus, if it's some versions of McAfee or Norton or Panda, it may have a firewall function, turn it off.

    To check the Windows firewall, go into Control Panel and click Security Center. There should be a link to firewall settings on the bottom, turn that OFF on both PCs as well.
    Then try to connect to the shared printer again.

    I personally think it's a firewall problem, as XP is normal extremely easy for printer sharing. In fact, if certain settings are in place, XP will automatically find and install shared printers, without you even having to do anything.

    Good luck
  3. zaahidkhan

    zaahidkhan Newcomer, in training Topic Starter

    i have tried the advise you gave me but still does not seem to work. its becoming rely annoying. there is one detail i may hav forgoten to give you, and that is when i try and add a printer from the other pc, i got to add printer uder printer and faxes in control panel, and when i click add printer and browse for a printer i just get 'microsft wondows network' in the printers selection. and yes my computer is xp pro, other pc is xp home
  4. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Hmm, I still suspect a firewall issue. But if the printer PC is XP Pro, go to the Security tab in the properties of the printer and make sure the "everyone" group has full control on the printer. If that exists. I think it does, can't check.

    In the browse for a printer box where it says 'microsoft windows network' is there a plus (+) sign next to it? It should expand and list your current work group and so forth. If it doesn't even SEE the other computer, let alone the printer, then something is fishy. That kind of behavior either suggests no physical connection or the network is being blocked (firewall). If not software then check the settings in your router itself.

    One test might be to look at the network settings and ping the other box. Go into Control Panel again and on the left side click the "classic" view. Go into Network Connections. Right-click local area network and choose properties. Double click the Internet Protocol (TCP/IP) options to enter settings area. If everything is automatic, then great, if not, write down all the IP addresses. If you have information set statically, then that could be a problem.
    If it is NOT set statically, then do this: Back in the Network Connections window, double click your Local Area Connection, or whatever your currently using. Go to the Support tab, write down the addresses there. Check this stuff on both PCs.

    All these addresses should be in sync. They should have the same gateway, same Subnet, and almost same IP. In the form of 192.168.0.100 and 192.168.0.101 or maybe 192.168.1.50 and 192.168.1.51 or something like that. If the numbers are off, that is an issue. What are the numbers on the two PCs?
  5. zaahidkhan

    zaahidkhan Newcomer, in training Topic Starter

    both pc setting are in sync like you sed, the ip adresses differ slighty, like my pc is 192.168.0.3 and the other is 192.168.0.2 as you said they might. i don't believe it can be my norton firewall because i tried it with it disabled on both pc's. i think it might be the one in my netgear dg834 router, but i am not sure. thanks for helping me, keep going!! how would i check? or are there anymore setting to be checked first?
  6. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Can you find your way around in the Norton Firewall? If you can check the blocked and allow lists see if has your system in there. Or leastaways just check everything that says "blocked".

    I think there is also settings in there for allowing network connections to/from your PC from somewhere in the program. Which you'd have to check on both PCs.

    What is very strange is that, even if you turn the firewall off in Norton, it will continue to block certain things anyway, I learned this the hard way.
    Besides, when you try to connect between PCs, Norton didn't pop up asking if you want to allow the connection? It could be automatically blocking without telling you.

    What version of Norton? What year? I might be able to research it.
  7. tdeg

    tdeg Newcomer, in training Posts: 348

    This is good (I think). When you double click on Microsoft Windows Network it will take a while, but your other PC should show up. Double click on it again. It should show your printer at that point.
  8. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Did you get your printer loaded yet? Just wondering if it was firewall after all.
  9. knownothing

    knownothing Newcomer, in training

    Vigilante,

    I've got a similar problem setting up a shared printer on my network.

    My main PC is a desktop, Windows XP Home. My laptop is also Windows XP Home. I've got them linked already with internet connection, and I just managed to get both to share files yesterday (that was a battle). I'm using a Lyksis Wireless G router WRT54G.

    My latest challenge is the laptop cannot find a printer on the network. I don't have the security option of the windows firewall on the main pc (I have no known firewall), yet I do on the laptop. I disabled the firewall on the laptop, then enable it after successfully sharing files. I have not downloaded the firewall provided by AOL 9.0 just yet on the main PC.

    I have selected the "Share this printer" command as you mentioned in your first reply in this thread.

    Your advice would be greatly appreciated.

    Thanks,

    Charles
  10. RealBlackStuff

    RealBlackStuff Newcomer, in training Posts: 8,165

    If all else fails, then both of you could look for a print-server. That hooks into the router with an ethernet cable, allowing the whole network to share it independently. No more need to have the PC with the printer 'attached' ON.
    Printservers come in USB and parallel, so make sure you get the correct one for your printer.
  11. knownothing

    knownothing Newcomer, in training

    Woo-Hoo! I got it to work!

    When I re-read tdeg's post, the description looked very familiar. I didn't even think to double click the PC's listed on there, which was there all along! I double clicked on the Main PC, and selected my printer...voila. Tested the printer, it was almost immediate that it began printing.

    Thanks everyone! Hopefully zaahidkhan will have the same result!

    Charles :grinthumb

    tdeg tdeg is offline
    TechSpot Member

    Join Date: May 2005
    Posts: 68
    Quote:
    Originally Posted by zaahidkhan
    ... when i click add printer and browse for a printer i just get 'microsft wondows network' in the printers selection. ...


    This is good (I think). When you double click on Microsoft Windows Network it will take a while, but your other PC should show up. Double click on it again. It should show your printer at that point.
  12. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Nice guys, I only wish I HAD a printer to HAVE trouble with. I have like 5 printers laying around all of which need work of some kind :(

    Did I mention I don't particularly care for Norton? Especially the firewall? Did I mention I don't particularly care for ANY software firewall? Oh well.
  13. fidadida

    fidadida Newcomer, in training

    I have the same problem. But I do agree it's the firewall that keeps me from accessing a printer attached to this PC. You suggested to disable the firewall, but wouldn't that make the whole network vulnerable to virusses & stuff?

    I only have Windows firewall, so I'm not sure if I want to disable it. I've had bad experience before for not turning on the firewall.

    I have one laptop which the windows firewall wasn't turned on, and I tried to access a printer attached to that laptop from this PC, and it worked, but when I tried to access a printer on this PC from the laptop, it won't detect any printers connected to this PC.

    I really need to make this home networking thing work because in this house we have like 5 - 6 laptops and only one printer which is located in my room, and they like to bother me at midnights just to use my PC and the printer. Help please :(
     
  14. technicalfury42

    technicalfury42 Banned Posts: 109

    This is the best solution, since like you said the PC does not need to be involved (or on).
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.