HP 430 laptop webcam not detected

By aamna khan
Jan 6, 2014
Post New Reply
  1. Hello, the product code of my laptop is HP 430 B4U59PA#ACJ. windows 7, 64 bit. I have built in camera. It was working nicely at starting but since one year now its not working. whenever I open my cyberlink youcam I get this error "no webcam detected.try plugging in a webcam into your computer now. if you are using an integrated camera,make sure that is turned on." I tried re installing but it didnt work. I checked my device manager. The snap short of the same is below.

    I entered msinfo32 in the run. In components>problem devices. The following list appears-

    Ethernet Controller PCI\VEN_10EC&DEV_8168&SUBSYS_3674103C&REV_06\4&2516744&0&00E0 The drivers for this device are not installed.
    Not Available ROOT\WPD\0007 The drivers for this device are not installed.
    Not Available ROOT\WPD\0008 The drivers for this device are not installed.
    Not Available ROOT\WPD\0013 The drivers for this device are not installed.
    Not Available ROOT\WPD\0015 The drivers for this device are not installed.
    Not Available ROOT\WPD\0016 The drivers for this device are not installed.
    Not Available ROOT\WPD\0017 The drivers for this device are not installed.
    Not Available ROOT\WPD\0018 The drivers for this device are not installed.
    Not Available ROOT\WPD\0019 The drivers for this device are not installed.
    Not Available ROOT\WPD\0000 The drivers for this device are not installed.
    Not Available ROOT\WPD\0001 The drivers for this device are not installed.
    Not Available ROOT\WPD\0002 The drivers for this device are not installed.
    Not Available ROOT\WPD\0003 The drivers for this device are not installed.
    Not Available ROOT\WPD\0004 The drivers for this device are not installed.
    Not Available ROOT\WPD\0005 The drivers for this device are not installed.
    Not Available ROOT\WPD\0006 The drivers for this device are not installed.
    PCI Device PCI\VEN_10EC&DEV_5209&SUBSYS_3674103C&REV_01\4&34822278&0&00E4 The drivers for this device are not installed.

    Attached Files:

  2. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    By default, Device Manager shows a device if it's connected and powered on.
    > None of those hardware IDs are your web cam
    > Look through Dev Manager under imaging device, USB devices and see if any "Other" device entries. Anything look like your cam? Any line item with a yellow icon (Other then the Ethernet and Network controller devices)

    If not, then check if any way to power/on off the cam. Any on/off functions or switches on your laptop for the cam. If not, the cam must have failed. Unfortunately, I see alot of that problem on this forum
  3. aamna khan

    aamna khan Newcomer, in training Topic Starter

    There is no imaging device under device manager. The snap short of the device manager is attached below.
    Do you know how to on/off the cam coz I am not able to find a way to do so.
    My voice recorder is also not working since the day my webcam stopped working.

    Attached Files:

  4. LookinAround

    LookinAround TechSpot Chancellor Posts: 8,358   +167

    Indications are you web cam has died :'( I've seen a lot of laptop web cams fail (especially HP laptops) in these forums.

    btw... The PCI devices in your report are for
    > Ethernet Controller - for a cabled internet connection
    > The other PCI device is your onboard card reader.
    They're both missing drivers.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.