html IE icon problem

By satnone
Sep 9, 2005
  1. P4 3GHz.. 1GB ram.. windows 2000 server

    anybody know whats goin on here?? ive searched the internet and tried everything for 3 days now...


    i can change the file association and it will show the new icons... but if i put it back to IE all i get is the generic no association icons... ive tried reinstalling IE also... along with all sorts of other obvious things i tried... so if anybody has any (more advanced i guess i should say) ideas please let me know...
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    You need to go 1 step further, in that association, you also need to change the matching ICON.
    In Explorer, click on Tools/Folder Options/File Types/
    Scroll down to HTM, click on it and select Advanced.
    On the next screen select Change Icon and Browse to \program Files\Internet Explorer\iexplore.exe
    Pick an icon from there.
    Repeat this for HTML
  3. satnone

    satnone TS Rookie Topic Starter

    yeah ive already tried that.. doesnt work...
  4. satnone

    satnone TS Rookie Topic Starter

    i fixed it :)

    if anybody comes across this thread with the same problem this is what u need to do

    its a problem that happens to some people.. programs add a key to the registry that changes the default icons.. in this case it was GoLive


    is the key that refers to


    which has this key

    HKEY_CLASSES_ROOT\CLSID\{42042206-2D85-11D3-8CFF-005004838597}\Old Icon\htmlfile\DefaultIcon

    which has an invalid path or something.. u can either fix the path.. or just delete


    all together.. which is what i did.. u really dont need it :)
  5. greenflash

    greenflash TS Rookie Posts: 100

    tx for the info satnone
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...