I am having problems installing updated Drivers for my Graphics Card

By Kam
Dec 15, 2004
Topic Status:
Not open for further replies.
  1. I am having problems installing the Sapphire Radeon Catalyst driver after downloading it from the Sapphire Tech website. After the software set-up is finnished and I restart the PC, the Hardware update Wizard pops up and at the bottom right handside of the screen it states new hardware found.

    The Hardware Update Wizard set-up has the option to install software automatically or from a specific location. When it searches for the software it tells me the hardware was not installed becouse it could not find the software and the setup wizard is also unable to locate the software.

    I then have to close the window and I get a pop-up from the bottom right hand side stating the new hardware was not installed properly and will not function properly.

    On the Device manager, there's 2 yellow question marks next to "Other devices" and "Unknown device"

    Can someone please tell me how I can install the graphic card driver properly and not get the yellow question mark.
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,763

    Try the drivers from ATI.com. Catalyst 4.12. They will install automatcally.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.