I cannot connect to one specific site for some unknown reason.

By headbanger
Jun 5, 2006
  1. There's a website that, for some reason, I cannot connect to. Each time I try to, Firefox just gives me the old error:

    The server at is taking too long to respond.

    (the site = by the way)

    The same thing happens on all of my web browsers, and in fact no computer on the network at my house that's connected to the Internet can go to the site, though I know it's not down. I'm not IP-blocked from the site, and I can still visit it through proxies.

    What could be causing this, and what can I do about it? I hate having to go through a proxy everytime I want to use it. :/
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    It may be something to do with your ISP. Hence why using a proxy lets you contact the site.

    The reason I say this, is because my ISP has been having a few problems lately and I`ve had the same problems connecting to certain sites, although in my case the problem is intermittent.

    Contact your ISP and see what they say.

    If it turns out it`s nothing to do with your ISP, then I don`t know what the problem is.

    Regards Howard :wave: :wave:
  3. korrupt

    korrupt TS Rookie Posts: 716

    it may be spyware. Download spybot search&destroy and ad aware and run a spyware scan on both.

    Good luck


Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...