TechSpot

I get this weird delay when opening file explorer or anything from the win + x menu

By cadienphoenix
Aug 16, 2015
Post New Reply
  1. So I recently re-installed windows 8.1 pro and I've been noticing that when I open file explorer or anything from the win + x menu I get maybe a second (probably less) delay that's not there if I were to search for it or open it basically anywhere else. File explorer has a delay no matter where I open it, but if I were to open one of my recent files from the jump list, it opens quickly. I know this seems like a weird and trivial issue but I just wanna know if this is normal or not.
     
  2. cadienphoenix

    cadienphoenix TS Rookie Topic Starter

    Okay well it seems my file explorer is kind of faster than it was before so nvm I guess
     
  3. cadienphoenix

    cadienphoenix TS Rookie Topic Starter

    Ok well it is actually my intel chipset drivers for my motherboard and everything is working as intended. I'm a noob.
     
  4. jobeard

    jobeard TS Ambassador Posts: 9,351   +622

    In your viewer options, don't view directories as icons or contents, use List or Details
     
  5. cadienphoenix

    cadienphoenix TS Rookie Topic Starter

    thanks, I think it actually did help a little, I don't know if it could be placebo though. I have gotten used to it and barely notice it now, thank you though.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...