TechSpot

IE 6 Won't load secure pages (SSL, HTTPS)

By boseith
Jun 6, 2003
  1. I've been trying to help out a friend running Win XP Home Ed. A few days ago they were unable to load up secure web sites. They have been able to in the past, now it's not working. They have IE 6 with SP1, it says it has Cypher Strength 128bit.

    I've reset the web setting under the programs tab in Internet Options, and reset the setting on the default page - Didn't help any, they do have SSL 2.0 and SLL 3.0 checked on the advanced tab.

    Tried running the reinstall/repair option for IE 6 in XP, by going to Start, Run and typing sfc /scannow - Didn't work.

    We have installed Netscape 7 and it does pull up secure sites, so I do know it's a problem with IE.

    Other than running the repair option for windows xp, I was wondering if there are some other things I can try.
     
  2. Goalie

    Goalie TS Rookie Posts: 703

    As a knee jerk reaction, clear the cache. That never hurts, and frequently helps.

    What do you mean by SSL not working? Is the site refusing authentication, or the page staying blank, or??? More information about system specs and problem details would help greatly.

    Searching MS's Knowledge Base, I see the following potentially relevant articles:


    NTLM Authentication Over an SSL Connection Does Not Work in Internet Explorer 6
    http://support.microsoft.com/default.aspx?scid=kb;en-us;325662

    Cannot Connect to Web Sites That Require SSL 3.0
    http://support.microsoft.com/default.aspx?scid=kb;en-us;318815


    Page Cannot Be Displayed Error During SSL 3.0 Server Session Timeout
    http://support.microsoft.com/default.aspx?scid=kb;en-us;305217


    An Error Occurs in Ssl.dll When You Try to Start Internet Explorer
    http://support.microsoft.com/default.aspx?scid=kb;en-us;817833


    Hope this helps some!!
     
  3. JackieChanIsGOD

    JackieChanIsGOD TS Rookie Posts: 83

    Download Mozilla...
    And your problems magically distapear!
     
  4. Jon Pickles

    Jon Pickles TS Rookie

    Jon Pickles

    I have exactly the same problem accessing secure sites - except it happens under IE6, Netscape 7.2, and Mozilla.

    Under IE6 after a wait of about 20 seconds you get the standard DNS error page. Under the others you get the message "connection to the site unexpectedly terminated".

    Any assistance greatly appreciated. I have searched all the Microsoft support sites, ensured by Internet options have SSL 2.0 and 3.0 enabled, etc. etc.
     
  5. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,916   +9

    Is there a firewall blocking port 443? https uses that.
     
  6. JLovegren

    JLovegren TS Rookie

    Same Problem, WinXP won't load SSL

    I have the same problem. My notebook is part of a domain. Over the holidays, I was trying to configure EFS to encrypt a folder's contents and I was told I needed a file recovery agent installed.

    I tried to create my own certificate to do this and ended up deleting some old expired certificates. Maybe this is where the problem started.

    I created a certificate for file recovery on the domain and exported it and installed in on the notebook. I was able to use EFS.

    Now a couple of weeks later I noticed that I was not able to access any SSL or 443 sites. It seems to be related to windows as I downloaded a different browser and I had the same problem. It is not on the firewall because I have two machines at home and the other one works fine.

    With this information, does anyone have any ideas?

    dl'd mozilla as per an earlier thread and it worked. still would like to know how to fix the orig. problem. :dead:
     
  7. greglanders

    greglanders TS Rookie

    same thing going on here too...

    Same problem here too. I have several browsers (IE6, Firefox, NS7, NS4.5, Opera) on this machine and not one of them will load a secure address. I also have other computers on the same LAN and they do not have this problem. It just started a couple of days ago ... really frustrating :mad: .

    I really hope a solution shows up soon. I am all ears. Likewise, I will post if I find a fix.
     
  8. greglanders

    greglanders TS Rookie

    I found the cure!

    I FOUND IT!

    Basically I found an article at Microsoft's site entitled "How to troubleshoot situations where you cannot complete MSN sign-up or connect to SSL secured (128-Bit) Web sites by using Internet Explorer in Windows XP" ... for some reason this forum is not letting me add a link to the article. Let me know if you can't find the article and need a link.

    To make a very long story short ... all I had to do was re-register the following .dll files:

    Softpub.dll
    Wintrust.dll
    Initpki.dll
    Dssenh.dll
    Rsaenh.dll
    Gpkcsp.dll
    Sccbase.dll
    Slbcsp.dll
    Cryptdlg.dll

    To re-register these files, follow these steps:

    -----------------------------------------------

    1. Click Start, and then click Run.

    2. In the Open box, type one of the following commands, and then click OK (copy and paste is your best friend):

    regsvr32 softpub.dll
    regsvr32 wintrust.dll
    regsvr32 initpki.dll
    regsvr32 dssenh.dll
    regsvr32 rsaenh.dll
    regsvr32 gpkcsp.dll
    regsvr32 sccbase.dll
    regsvr32 slbcsp.dll
    regsvr32 cryptdlg.dll


    4. Click OK when you receive the message that says DllRegisterServer in FileName succeeded.

    5. Repeat for each command line listed above

    -----------------------------------------------

    That's it!!! SECURE PAGES WILL NOW LOAD ON THIS COMPUTER! :bounce:

    I hope this helps some of you out there.

    Take care,
    Greg Landers
     
  9. snewton

    snewton TS Rookie

    wouldn't work for me

    i have same problem started just few days ago. i did the last suggestion on here, with every one i put in saying it was successful. but when i went to view the secured pages same thing happened and they wouldn't load. any other suggestions???
     
  10. MrWalrus7777

    MrWalrus7777 TS Rookie

    Can view secure sites now!

    Hey I had the same kind of problem I think (i couldn't view secure pages, the ones that begin with h_t_t_p_s) and I was getting really bummed so I just went to Control Panel and turned off Windows Firewall completely. That fixed it! So then I read somewhere that the secure ports were 443, 84, and/or 8443. I put those port numbers in the exceptions list in Windows Firewall, and turned Windows Firewall back on. I can look at secure pages now! :unch: For some reason this only happened on my desktop and not my laptop, I don't know why. Hope this helps.
     
  11. fuchsel

    fuchsel TS Rookie

    Another possible fix

    I was having the same problem in IE, Firefox and Netscape. I couldn't log in to any secure site despite all my settings showing SSL enabled. browserhawk.com said my SSL was disabled. I tried all of the suggestions posted here. No go. What finally worked for me was uninstalling Norton Internet Security.
     
     
  12. Natalie

    Natalie TS Rookie

    Norton Was The Perpetrator

    I reluctantly uninstalled Norton as above mentioned and it did solve all my problems. *sigh* Maybe McAfee is the way to go. I've never heard of MA causing nearly as many problems as NAV.
     
  13. Vigilante

    Vigilante TechSpot Paladin Posts: 2,120

    Norton is notorious for continuing to "block" things even when the firewall is supposed to be off. It's not really "off".

    I really like Panda for an Antivirus/firewall :)

    Lastly, the DLL re-register trick is very common among techs, it solves not only SSL issues but ActiveX issues and others as well. Note that only a few are security related like "wintrust" but the others are a core part of IE as well.

    In very rare cases it has been a certificate problem. Or a protocol problem, as in bad handling of the "https" part in the registry. And even a couple times the fix was with the encryption itself, as in services, as in, properties of IE will say "0 bit encryption".

    cheers
     
  14. cillosis

    cillosis TS Rookie

    The fix...

    Hi, I am new to the forums thanks to this very issue. I thought I would post my fix that works better than uninstall/reinstall. So here goes:

    1) Open Norton Internet Security
    2) Double Click "Personal Firewall"
    3) Click the "Advanced" Tab
    4) Click the "General" button which is incoming/outgoing basic rules.
    5) Search for the one that says "Block Access to Secure Sites"
    6) Uncheck it. Press "OK", then Press "OK" again.
    7) Now it will work because Norton is no longer blocking access!

    [​IMG]
    I hope that helps some people! :)

    .:Jeremy:.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.