If you have Counter-Strike: Source problems, read this!

By mopar man
Jun 13, 2007
Topic Status:
Not open for further replies.
  1. I am creating this thread to try to reduce some of the CS:S problems being posted.

    Requirements:

    Minimum: 1.2 GHz Processor, 256MB RAM, DirectX 7 level graphics card, Windows 2000/XP/ME/98, Mouse, Keyboard, Internet Connection


    Recommended: 2.4 GHz Processor, 512MB RAM, DirectX 9 level graphics card, Windows 2000/XP, Mouse, Keyboard, Internet Connection

    If you don't know whether or not you meet this, go here:
    How to check system requirements before you buy the game.

    If you have an integrated graphics card, or have a low-end Dell, such as the 2400,3000, etc. then you will most likely need to buy a graphics card for it to run at least decently.

    If you have a low-end CPU, go HERE

    You can also GOOGLE Caseys config. It is an Autoexec file that lowers the settings on a lot of stuff and increased my fps by about 20.

    If you haven't already, make sure that you have already uptated your Graphics Cards Drivers.

    Ati go HERE

    nVidia go HERE

    If you are having problems with your Ati drivers, try the Omega third party drivers HERE
    They currently do not have third party drivers for nVidia.



    Do you have a skip or stutter that occurs every few seconds? E.G, Every three seconds there is a slight skip? If you do, then you can try disabling processes through task manager. To find out which ones you can disable, go HERE.


    Wonder if your problem may be a bug? Go HERE

    Having Steam problems? E.G, Update causing you problems. Go HERE

    Are you having problems running a Dedicated Server without lag? If so, try taking a look at THIS.

    Some programs interfere with Steam, go HERE to see a list and what to do.

    Go HERE to troubleshoot network problems.

    Go HERE to troubleshoot game crashes.

    If your problem was not solved here, search around in VALVe's CS:S forum HERE.

    Have you tried googling your problem? A lot of time, other people have the same problem. Google!

    If you STILL cannot find your answer, use the Steam Support Center HERE.

    I don't recommend using the support center unless you have to, because it can take FOREVER to get a decent reply.

    Rates Information:
    If you notice that your latency is off, or your shots are not registering, set your rates accordingly by opening up the Console (~ key) and type the following command(s) in:
    Rate 25000
    cl_updaterate 101
    cl_cmdrate 101


    If nothing here helps you, be free to post!
  2. beef_jerky4104

    beef_jerky4104 Banned Posts: 1,094

    Great post. Maybe even a sticky?
  3. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    I don't know. If anyone has any additions, please let me know.
  4. beef_jerky4104

    beef_jerky4104 Banned Posts: 1,094

    Maybe if the drivers they downloaded were messed up the should go to www.omegadrivers.net for third party drivers.

    Also these drivers are mostly for ATi cards. The NVIDIA program is on hold.
  5. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    Updated, and spell checked it ;).
  6. mailpup

    mailpup TS Special Forces Posts: 8,386   +205

    Spell checked? :)
  7. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    :p


    I swear I do that every time. I had to hand check it, and I tend to misspell recommend a lot. :confused:
  8. mailpup

    mailpup TS Special Forces Posts: 8,386   +205

    That's okay. I was just teasing you anyway. Good post BTW.
  9. beef_jerky4104

    beef_jerky4104 Banned Posts: 1,094

    Also I'd like to add that some programs block CS:S. Like "Pure Sight".

    It stops CS:S completely.
  10. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    Thanks beef, now one question. Do you like the new format better? Or should I go ahead and switch back to the old one?
  11. beef_jerky4104

    beef_jerky4104 Banned Posts: 1,094

    I perfer the older format. It's less complicated making it easier to read.
     
  12. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    Ok, I added something about the Intedgrated graphics card.

    Is there nothing else someone can add?

    It needs something about the connection aside from the link. I don't know crap about the connection so if anyone can contribute, please do so!

    Thanks.
  13. beef_jerky4104

    beef_jerky4104 Banned Posts: 1,094

  14. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    I think more people need to see this.. :)
  15. munch2477

    munch2477 Newcomer, in training Posts: 149

    Ok ive read this and have done pretty much everything i can do to my computer. I actually used another guys config which i think works better than casey config.

    http://forums.steampowered.com/forums/showthread.php?s=&threadid=453432

    I went from around 60 fps to around 120 in video stress test. But even with that my in game fps stays around 40. I can't figure out what else to do. I am also having trouble with installing new drivers for my video card. Keeps saying i need .net 2.0 or something which i downloaded and then it says it cant find hardware i need. I dunno. anyone else have this problem?
  16. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    I don't know munch, I haven't seen anything about it.

    bump :p
  17. munch2477

    munch2477 Newcomer, in training Posts: 149

    Yeah that post is old. I have solved my problems though without the driver issue. As i originally suspected, my laptop had serious heat problems. I used CCleaner, tweaked windows, and used a custom cfg for starters. Then to solve the heat problem i used two plastice pieces and lifted the back of my computer up an inch and i directed a fan underneath my laptop. Now i get 100-120 fps in game. And my computer runs a lot faster.
  18. Ftowngang916

    Ftowngang916 Newcomer, in training Posts: 33

    Server not responding

    First thing, I am a complete ***** when it comes to computers. I just installed CS:S to my computer and everything was going fine. I installed steam for the first time and hit the servers button. The list of servers came up and I went to click a server to join. The info came up that the server is not responding. I continued to try a variety of servers and the same thing everytime. I dont know if this relates but under my games section, It says CS:S preload is complete. I am not sure if that means that it is installed or not. I did not ever enter the cd-key also. I have Disc 1 in the cd rom drive and everytime i try and click "play cs:s, it just brings up the steam box. Thanks any help is appreciated. :)
  19. death_by_sk8

    death_by_sk8 Newcomer, in training

    well, I have tried to change the Configs and everything. I got a good config, and I know my computer is good (I bought it two days ago.) I downloaded the latest drivers and everything, BUT MY CS STILL LAGS! I changed the settings all to either low or off and i still lag. The resolution is also on the lowest. Can someone please help me?
  20. death_by_sk8

    death_by_sk8 Newcomer, in training

    by the way, after the video stress i got a 9.00 FPS. Don't know if that's good, but it's what i got
  21. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    To death_by_sk8:

    Go to Start, then Run. Type in dxdiag, then hit enter. It should say Memory: ???Mb/Gb. That is your ram. Tell me that and then click the Display tab. it should say Name: ???
    Tell me the name of the graphics card that is says there.


    Also, make sure you don't have any Anti Virus programs or anything like that running in the background (Mcafee, norton (god help), or AVG).


    Also make sure that your sound quality is set to low.
  22. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    To Ftowngang916:

    I am not sure what is happening there, but you should have entered your cd-key when creating your account to access the games. Also make sure that you don't have any firewalls running, such as Comodo or windows. Go to Start, Control Panel, Security Center, and then see if Windows Firewall is on. If it is, go HERE.


    Hope you get it fixed.
  23. munch2477

    munch2477 Newcomer, in training Posts: 149

    well seeing as the more fps the better, a 9.00 sucks. you probably want something closer to a 60 for decent game play. what kind of computer do you have? list all specs
  24. beef_jerky4104

    beef_jerky4104 Banned Posts: 1,094

    That is a horrible score.
  25. mopar man

    mopar man TechSpot Ambassador Topic Starter Posts: 1,492

    BUMP


    There are some people that need help.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.