IIS 6 and web site hosting

By Big-Z
May 31, 2005
Topic Status:
Not open for further replies.
  1. I'm trying to set my server up to host a web site (with a virtual dir) available only to people i know. The way I did this in Win Server 2k3 Web Edition was straightforward and worked. I have now upgraded to Server 2k3 Standard and have got stuck.

    I set IIS up exactly how it was on Web Edition. The main difference with the server now is that it is now a domain controller, runs active dir, and is a dns server. To be honest, DNS scares me mainly because I don't know what I'm doing. The web site is accessible locally, and works fine in all respects. But when trying to connect externally, i get to the login screen, enter name + password and then it times out. The web site has anon access turned on, port 80 is forwarded from router, and I read somewhere that these things could be caused by DNS issues (i wouldn't really know if this was true).

    My local domain is named differently from my web domain as I get all queries sent to my web domain forwarded to my ip. It is then forwarded from router to the server (pretty standard). I just don't get why it worked on my old version of Server (Web Edition), when it is set up exactly the same. I guess it's something to do with the new roles my server is playing (like DNS etc). Can someone please help? You guys at TechSpot have never failed me yet!

    If you need more info, then let me know.

    Thanks

    Dave
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.